php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40874 .msi download comes through as text/plain
Submitted: 2007-03-20 22:37 UTC Modified: 2007-05-06 17:06 UTC
From: dave at psntn dot com Assigned: bjori (profile)
Status: Closed Package: Website problem
PHP Version: Irrelevant OS: Windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
28 - 4 = ?
Subscribe to this entry?

 
 [2007-03-20 22:37 UTC] dave at psntn dot com
Description:
------------
When downloading the "PHP 5.2.1 installer" msi file, the server sends back a Content-type of text/plain instead of whatever it should be

Reproduce code:
---------------
Download from here:

http://www.php.net/get/php-5.2.1-win32-installer.msi/from/a/mirror

Expected result:
----------------
A box would pop up asking to save/open file

Actual result:
--------------
Web browser (Firefox and Opera but not MSIE) attempts to render it as plain text and promptly crashes (having maxed out the CPU).

The HTTP response from the server is as follows:

HTTP/1.x 200 OK
Date: Tue, 20 Mar 2007 22:31:11 GMT
Server: Apache/2.2.2 (Fedora)
Last-Modified: Mon, 12 Feb 2007 14:31:48 GMT
Etag: "1497f-131c008-5e943d00"
Accept-Ranges: bytes
Content-Length: 20037640
Connection: close
Content-Type: text/plain; charset=UTF-8


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-03-21 11:14 UTC] bjori@php.net
Which mirror was that?
 [2007-03-21 13:28 UTC] dave at psntn dot com
It only seems to be with the uk* mirrors.  I've tried about 5 others and they all pop the download box up (although the ones I observed sent back text/plain too).
 [2007-03-21 14:23 UTC] jonathon at fubra dot com
I've just tried a random selection of other mirrors and found the same problem on us3 and sg as well as all the uk mirrors.
 [2007-03-21 15:46 UTC] bjori@php.net
I've upgraded our mirroring recommendation and will contact the affected mirror maintainers..

Thanks
 [2007-04-10 10:13 UTC] bjori@php.net
Update: ge, gr2, ir, il, jp2 & us3 are still affected.

 [2007-04-10 11:12 UTC] bjori@php.net
I disabled these mirrors and mailed the maintainers again.
 [2007-05-06 17:06 UTC] philip@php.net
Here's an email that explains the fix:

http://news.php.net/php.mirrors/34971
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Apr 17 05:01:34 2024 UTC