php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4084 can't find symbol __dn_skipname
Submitted: 2000-04-08 22:09 UTC Modified: 2000-08-15 20:01 UTC
From: ltong dot 1 at email dot com Assigned:
Status: Closed Package: Dynamic loading
PHP Version: 4.0 Release Candidate 1 OS: SunOS 5.5
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ltong dot 1 at email dot com
New email:
PHP Version: OS:

 

 [2000-04-08 22:09 UTC] ltong dot 1 at email dot com
I configured the php with "--with-apxs=... --prefix=... --with-mysql=...".
it was compiled and installed smoothly except some compilation warning.
but, i couldn't start my apache with the php module enable, and got the following error message:

plato$ ./apachectl start
Syntax error on line 224 of /plato1/home/cats/conf/httpd.conf:
Cannot load /plato1/home/cats/libexec/libphp4.so into server: ld.so.1: /plato1/home/cats/bin/httpd: fatal: relocation error: symbol not found: __dn_skipname: referenced in /plato1/home/cats/libexec/libphp4.so
./apachectl start: httpd could not be started
plato$ 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-30 13:06 UTC] zak@php.net
Have you tried a current release of PHP?  If so, does the problem still occur?
 [2000-07-30 19:56 UTC] ltong dot 1 at email dot com
SunOS 5.5 is too old. /lib/libresolv.so is originally linked to /lib/libresolv.so.1 on 5.5, which should be linked to /lib/libresolv.so.2 instead. __dn_skipname only appears in libresolv.so.2.
 [2000-08-15 10:21 UTC] waldschrott@php.net
What?s the current status of this bug now?
 [2000-08-15 20:01 UTC] sniper@php.net
User reported problem solved.

--Jani
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Sep 28 13:01:23 2020 UTC