php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40774 Inconsitent XMLwriter::writeDTD
Submitted: 2007-03-11 12:12 UTC Modified: 2007-08-23 14:04 UTC
From: james dot zimmerman at comfreeze dot net Assigned:
Status: Not a bug Package: XML Writer
PHP Version: 5.2.1 OS: Windows XP SP2/Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: james dot zimmerman at comfreeze dot net
New email:
PHP Version: OS:

 

 [2007-03-11 12:12 UTC] james dot zimmerman at comfreeze dot net
Description:
------------
I have a home development server based on XAMPP full install where this code works fine.  Uploaded to web server hosting with Dreamhost and the Public and System tags fail reporting no space between SYSTEM and PUBLIC parts of the DTD output.  Both systems are reporting PHP 5.2.1 and are using SQLite 2.8.17, only inconsistency is Dreamhost phpinfo also lists PDO_SQLite @ 3.3.7 but SQLite databases create with standard calls appears to be generating the same SQLite 2.1 base files on both systems.

Reproduce code:
---------------
$outputWriter->writeDTD('html','-//W3C//DTD XHTML 1.0 Strict//EN', 'http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd');

Expected result:
----------------
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">

Actual result:
--------------
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN""http://www.w3.org/TR/html4/strict.dtd">

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-03-11 12:26 UTC] james dot zimmerman at comfreeze dot net
Was extremely tired when I wrote this original message and accidently reference a large chunk about SQLite which is also heavily used in this process I'm having trouble with but not in the area I am reporting a bug.  I have two hosts, 1) XAMPP Full Install - Windows XP SP2, 2) Dreamhost - Shared Host.  Both report running PHP version 5.2.1 and yet I am experiencing difficulty with the writeDTD tag when working source on XAMPP is migrated to Dreamhost shared hosting.  Basically on the Dreamhost side the writeDTD tag is neglecting a space between the SYSTEM and PUBLIC fields of the DTD causing it to error on validation parsing.
 [2007-03-11 12:33 UTC] rrichards@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Your libxml2 versions are different - issue fixed in libxml2 2.6.23.
Try turning indenting *ON* before writing DTD - I think this might work as a workaround with pre .23 libs.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Fri Nov 16 03:01:26 2018 UTC