php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40742 Call to undefined function preg_replace()
Submitted: 2007-03-06 21:01 UTC Modified: 2007-03-06 21:13 UTC
From: mirko dot viviani at gmail dot com Assigned:
Status: Not a bug Package: *Regular Expressions
PHP Version: 5.2.1 OS: FreeBSD 6.2-STABLE
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mirko dot viviani at gmail dot com
New email:
PHP Version: OS:

 

 [2007-03-06 21:01 UTC] mirko dot viviani at gmail dot com
Description:
------------
I have installed php5 with apache22 support from freebsd-ports, 
configured with this arg: --with-regex=apache
It does not seem to include the preg_replace() function:

[Tue Mar 06 20:18:13 2007] [error] [client xxxxxxx] PHP Fatal error:  
Call to undefined function preg_replace() in /usr...



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-03-06 21:13 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

--with-regex and --with-pcre-regex are two different options.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Dec 05 05:03:37 2021 UTC