php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40683 zend_operators.h generates discard qualifier compiler warning
Submitted: 2007-03-01 19:44 UTC Modified: 2007-03-12 09:29 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: lstefani at fortresstech dot com Assigned:
Status: Wont fix Package: Compile Warning
PHP Version: 5.2.1 OS: linux 2.6.12-1.1381_FC3smp
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
20 + 3 = ?
Subscribe to this entry?

 
 [2007-03-01 19:44 UTC] lstefani at fortresstech dot com
Description:
------------
Zend/zend_operators.h: In function `void* zend_memrchr(const void*, int, unsigned int)':
Zend/zend_operators.h:250: warning: cast from `const void*' to `unsigned char*' discards qualifiers from pointer target type
Zend/zend_operators.h:250: warning: cast from `const void*' to `unsigned char*' discards qualifiers from pointer target type


In code snippet, line 250 refers to the two recasts of argument s.

Reproduce code:
---------------
static inline void *zend_memrchr(const void *s, int c, size_t n)
{
  register unsigned char *e;

  if (n <= 0) {
    return NULL;
  }

  for (e = (unsigned char *)s + n - 1; e >= (unsigned char *)s; e--) {
    if (*e == (unsigned char)c) {
      return (void *)e;
    }
  }

  return NULL;
}


Expected result:
----------------
No compiler warnings.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-03-01 19:59 UTC] tony2001@php.net
What compiler do you use?
 [2007-03-09 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2007-03-12 00:08 UTC] lstefani at fortresstech dot com
Sorry for the late response.  Your email hit my company spam filter for some reason.  Just found it while going through the bulk mail folder.

To answer your question, I'm using the MIPS cross-compiler (GCC 3.3.2 and GLIBC 2.3.2) on Linux x86.  I know that's not the latest GCC compiler by a long shot, but just from reviewing the code, it does appear that the const declaration is being discarded by recasting the parameter as an unsigned char.
 [2007-03-12 09:29 UTC] tony2001@php.net
You can safely ignore it.
And no, I can't reproduce this warning with GCC4 & GCC3.4.6 or any other compiler.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Sep 15 10:01:26 2019 UTC