php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #40650 build system: include/require _once linking
Submitted: 2007-02-26 23:18 UTC Modified: 2007-03-28 13:34 UTC
From: philip@php.net Assigned: bjori (profile)
Status: Closed Package: Documentation problem
PHP Version: Irrelevant OS: OS X
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: philip@php.net
New email:
PHP Version: OS:

 

 [2007-02-26 23:18 UTC] philip@php.net
Description:
------------
require, include, and their _once siblings no longer link within the manual when using the <function> syntax. Previous builds did, so this appears to be a XSLT build specific problem.

Adding this bug so we don't forget.

Reproduce code:
---------------
<function>include</function>

Expected result:
----------------
A link to the manual page

Actual result:
--------------
No link

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-02-27 04:40 UTC] philip@php.net
.
 [2007-02-27 09:57 UTC] rquadling@php.net
Just so you know, a locally built extended CHM file built yesterday has the links working (with a cvs update prior to build). The make chm_xsl xml -> html conversion correctly picks up <require|include>[_once] and creates <a href>s accordingly.


 [2007-03-28 13:34 UTC] bjori@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Jun 25 04:01:31 2021 UTC