php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40570 GtkCellLayout inherition
Submitted: 2007-02-21 01:36 UTC Modified: 2008-03-16 15:20 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: theredtitan at hotmail dot com Assigned:
Status: Not a bug Package: PHP-GTK related
PHP Version: 5.2.1 OS: Windows XP SP2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: theredtitan at hotmail dot com
New email:
PHP Version: OS:

 

 [2007-02-21 01:36 UTC] theredtitan at hotmail dot com
Description:
------------
First of all, sorry for my bad english!!

I use PHP5 in both server side (With Apache 2.2), and client side (Using PHP-GTK)

After I installed the PHP-GTK v2.0 on my PHP 5.2.1, accedently the logos of both PHP and Zend that appears on the page of "phpinfo.php" has disappeared!!

I found that error occured when I added the "php.ini" setting:

extension=php-gtk2.dll

My error logs has repoted the following error:

[21-Feb-2007 04:18:43] PHP Fatal error:  Cannot inherit previously-inherited constant gtype from interface GtkCellLayout in Unknown on line 0



Reproduce code:
---------------
<?php
phpinfo();
?>

Expected result:
----------------
I expected to see the PHP and Zend logo with this codes:

phpinfo.php?=PHPE9568F34-D428-11d2-A769-00AA001ACF42
phpinfo.php?=PHPE9568F35-D428-11d2-A769-00AA001ACF42

Actual result:
--------------
What I saw when I query the "phpinfo.php" page was a blank page (As I configured the error logger to hide errors and log in to a file on my machine)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-02-21 12:51 UTC] auroraeosrose at gmail dot com
First of all, make sure you use the cli version of php (php.exe or php-win32.exe on windows..) with php-gtk2 - it is NOT meant to be used with a webserver or a webserver SAPI (isapi, apache2_2 module, cgi...etc)!

If you're running both a webserver AND php-gtk on the same machine you're going to need to use different php.ini files, your webserver ini file should NOT be loading the php-gtk2.dll  You can do this easily by setting the PHPINIDIR directive in your apache conf file or by renaming your php-gtk specific ini file php-cli.ini (a little known feature on windows is that php looks for sapi specific ini files - I have a php.ini, a php-isapi.ini, and a php-cli.ini all in the same directory...and IIS, apache, and the php cli always find the right file ;)
 [2007-02-25 12:44 UTC] yehac at hotmail dot com
This is a nice work around, but this does not fix the bug that we need to!!!
 [2007-02-25 13:33 UTC] auroraeosrose at gmail dot com
It's not a bug that php-gtk2 only works with the php cli sapi....

Perhaps it needs to throw an error when people attempt to load it with any other sapi "This only works with the cli version of PHP"
 [2008-03-16 15:20 UTC] auroraeosrose@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

This is a configuration error

if you "configured the error logger to hide errors and log in to a file on my machine"

you need to check your logs to discover why you get a "blank page" - in this case probably apache usually doesn't have access to your X display so when php-gtk is loaded you get a fatal error

The correct fix is to configure your machine so apache doesn't load the PHP-GTK extension
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jan 26 14:01:24 2020 UTC