php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40471 PHP 5.2.1 failed to be compiled with MySQl 5.0.33, MySQL 5.0.27, MySQL 5.1.15
Submitted: 2007-02-14 02:49 UTC Modified: 2010-12-20 12:25 UTC
From: pcdinh at gmail dot com Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 5.2.1 OS: CentOS 4.4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
33 + 26 = ?
Subscribe to this entry?

 
 [2007-02-14 02:49 UTC] pcdinh at gmail dot com
Description:
------------
I can not configure to build PHP 5.2.1 with MySQL 5 on CentOS 4.4. PHP can not find mysql_config that really exists.

User account used to build: root

Reproduce code:
---------------
MySQL (5.0.27/5.0.33/5.1.15) builds: 

./configure --prefix=/usr/local/mysql \
--localstatedir=/usr/local/mysql/data \
--libexecdir=/usr/local/mysql/bin \
--libdir=/usr/local/mysql/lib \
--with-server-suffix=-max \
--enable-thread-safe-client \
--enable-local-infile \
--enable-shared \
--enable-assembler \
--with-vio \
--with-libwrap \
--with-zlib-dir=bundled \
--with-big-tables \
--with-readline \
--with-archive-storage-engine \
--with-innodb \
--with-blackhole-storage-engine \
--with-csv-storage-engine \
--with-federated-storage-engine \
--without-embedded-server \
--without-berkeley-db \
--with-ndbcluster \
--with-ndb-docs \
--with-partition \
--without-docs \
--without-bench \
--with-charset=utf8 \
--with-collation=utf8_general_ci \
--with-extra-charsets=all \
--with-unix-socket-path=/usr/local/mysql/tmp/mysql.sock \
--with-client-ldflags=-all-static \
--with-mysqld-ldflags=-all-static \
--with-mysqld-user=mysql

Built successfully and MySQL running


PHP built:

./configure --prefix=/usr/local/php \
--disable-cgi \
--with-mysql=/usr/local/mysql \
--with-mysqli=/usr/local/mysql/bin/mysql_config \
--with-libxml-dir=/usr/local/lib \
--with-apxs2=/usr/local/apache2/bin/apxs \
--with-curl \
--with-curlwrappers \
--with-pdo-mysql \
--with-pdo-oci=instantclient,/usr/local/instantclient_10_2,10.2.0.3 \
--with-pdo-sqlite \
--with-oci8=instantclient,/usr/local/instantclient_10_2 \
--with-iconv \
--with-gd \
--with-png-dir=/usr/lib \
--with-jpeg-dir=/usr/lib \
--with-ttf \
--with-freetype-dir=/usr/include/freetype2 \
--with-dom=shared \
--with-dom-xslt=shared \
--with-dom-exslt=shared \
--with-xpm-dir \
--with-openssl \
--with-xml \
--with-zlib \
--with-bz2 \
--with-xmlrpc \
--with-mcrypt \
--with-tidy \
--with-mime-magic \
--without-pear \
--enable-dom \
--enable-png \
--enable-jpeg \
--enable-track-vars  \
--enable-memory-limit \
--enable-memcache \
--enable-calendar \
--enable-sysvsem \
--enable-sysvshm \
--enable-bcmath \
--enable-ctype \
--enable-exif \
--enable-ftp \
--enable-sockets \
--enable-shmop \
--enable-wddx \
--enable-gd-native-ttf \
--enable-mbstring \
--enable-path-info \
--enable-inline-optimization \
--enable-debug=no \
--enable-mbregex \
--disable-magic-quotes \
--enable-zip \
--enable-spl \
--enable-libxml \
--enable-simplexml \
--enable-soap \
--enable-sigchild \
--disable-static 

Error:

checking for MySQL support for PDO... yes
checking for mysql_config... not found
configure: error: Cannot find MySQL header files under

Screenshot:

http://www.flickr.com/photos/pcdinh/389717146/

Config log:
http://download.yousendit.com/63F59D0C1AA53E21

Expected result:
----------------
Be configured successfully.

mysql_config really exists. I have configured MySQL build with --libexecdir=/usr/local/mysql/bin and have set /usr/local/mysql/bin into the PATH variable



Actual result:
--------------
Failed to build

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-02-14 03:40 UTC] pcdinh at gmail dot com
Hi,

I just found out why PHP 5.2.1 final refused to build 

+ PHP 5.2.1 Rc4 does not require me to specify --with-pdo-mysql with MySQL path
+ But PHP 5.2.1 final requires it

So I need to add --with-pdo-mysql=/usr/local/mysql
 [2007-02-14 10:54 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 [2010-12-20 12:25 UTC] jani@php.net
-Package: Tidy +Package: MySQL related
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Tue Jun 06 23:03:36 2023 UTC