php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40393 pecl.php.net shows pecl deps as pear deps
Submitted: 2007-02-07 20:33 UTC Modified: 2007-02-07 23:55 UTC
From: helly@php.net Assigned: pajoye (profile)
Status: Closed Package: Website problem
PHP Version: * OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: helly@php.net
New email:
PHP Version: OS:

 

 [2007-02-07 20:33 UTC] helly@php.net
Description:
------------
pecl.php.net lists pecl dependencies as pear dependencies.

Example: http://pecl.php.net/package/phar
See bz2 which is actually a pecl package.

The only difference is that a pecl package has channel: pecl.php.net

It might also be interesting to have a direct link to the dependency. So bz2 would directly link to http://pecl.php.net/package/bz which we can easily do for channels pear.php.net and pecl.php.net

Reproduce code:
---------------
http://pecl.php.net/package/phar

Expected result:
----------------
List bz2 as pecl dependency

Actual result:
--------------
List bz2 as pear dependency

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-02-07 23:55 UTC] pajoye@php.net
This bug has been fixed in CVS. Since the websites are not directly
updated from the CVS server, the fix might need some time to spread
across the globe to all mirror sites, including PHP.net itself.

Thank you for the report, and for helping us make PHP.net better.

Btw, peclweb bugs go to pecl.php.net/bugs/ :)
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Jan 18 20:03:14 2022 UTC