php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40383 fdf-functions don't work
Submitted: 2007-02-07 09:42 UTC Modified: 2007-02-07 09:45 UTC
From: alexander dot schmidt at pc-handling dot de Assigned:
Status: Not a bug Package: FDF related
PHP Version: 5.2.0 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: alexander dot schmidt at pc-handling dot de
New email:
PHP Version: OS:

 

 [2007-02-07 09:42 UTC] alexander dot schmidt at pc-handling dot de
Description:
------------
1. Running XAMPP 1.5.5 on Windows with fdf-Support enabled and fdftk.dll version 5.0 (phpinfo says so), fdftk.dll available in System32 folder.

2. fdf_open("test.fdf"); results in the following error:

"A file system error occurred or the file was not found"

3. Crosschecked with file_exists() and is_readable() and both are true.

Reproduce code:
---------------
if (file_exists("test.fdf")) {
echo "File exists<br>";
 if (is_readable("test.fdf")) {
  echo "File is readable<br>";

   $fdf = fdf_open("test.fdf");
    if ($fdf) {
     echo "everything is fine, lets go!";
    }
    else {
     echo "Error: ";
     echo fdf_error(fdf_errno());
    }
  }
 else {
  echo "cannot read file";
 }
}
else {
 echo "file doesn't exist";
}

Expected result:
----------------
File exists
File is readable
everything is fine, lets go!

Actual result:
--------------
File exists
File is readable
Error: A file system error occurred or the file was not found

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-02-07 09:45 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Nov 13 00:01:32 2019 UTC