php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40282 Apache don't return right connection status
Submitted: 2007-01-30 05:29 UTC Modified: 2007-01-30 09:04 UTC
From: roberto at spadim dot com dot br Assigned:
Status: Not a bug Package: Output Control
PHP Version: 5.2.0 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: roberto at spadim dot com dot br
New email:
PHP Version: OS:

 

 [2007-01-30 05:29 UTC] roberto at spadim dot com dot br
Description:
------------
hello i'm writing an script to draw a graph
an explanation about script:
my graph is 1024x800 pixels and about 50000 points i'm using spline to get 1024 points (to draw less points and use less GD library, but using more cpu to run spline function)

the main problem is when my client (browser) stop work
since i'm running with set_time_limit(0) and ignore_user_abort(1) (i'm using temporary files to read points) i can't get right value from connection_aborted
i was reading manual and some users tell that connection_aborted only works when i "echo" some caracters, since i'm drawing images i can't change document content, if i change my image will be damaged and won't display on browser

can i get right connection_aborted status?!
thankx

Reproduce code:
---------------
<?php
 set_time_limit(0);
 ignore_user_abort(1);
 while(1){
   if (connection_aborted()) break;
   // i put connection aborted in many parts of my script, but this example could be something like i do
 }

?>

Expected result:
----------------
using htop i see that apache process cpu usage still high after stop from my firefox browser
apache should know that i stoped, maybe browser didn't send connection stop? or maybe apache didn't send connection stop to php? i'm using php as module an not as cgi!
expected result should be an process cpu usage with low values after stop from firefox

Actual result:
--------------
high cpu values (98%) on apache process
after stop (another process) run at (0.2% or less)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-01-30 09:04 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Jul 07 04:03:36 2022 UTC