php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40262 With or without snmp parameter, there is a shared access problem on conf files.
Submitted: 2007-01-28 12:05 UTC Modified: 2007-01-29 07:50 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: yolcu at sst dot gen dot tr Assigned:
Status: Not a bug Package: SNMP related
PHP Version: 5.2.0 OS: Linux CentOs 4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
3 + 38 = ?
Subscribe to this entry?

 
 [2007-01-28 12:05 UTC] yolcu at sst dot gen dot tr
Description:
------------
Configuring tith or without snmp parameter, there is a shared access problem on conf files related to snmp when cron jobs are used for more than 1 user in the same time period.

When run, snmp's conf files' owner becomes the cron job owner. At that time, if another request comes from another user, it'll give errors because that user is not the owner of that conf file! When i checked from console, i saw that the owner of the conf file continuously changes according to the cron job owner. if you disable and don't want to use snmp parameter nothing changes.

(By the way, there are NO compile errors.)

PHP version: 5.2.0
Net-Snmp version:5.4


( Before making all of my compiles, I have cleaned garbages: make distclean, make clean )

Reproduce code:
---------------
Compile the latest php stable released version 5.2.0

Assign cronjobs for more than 1 user in your system those call php scripts.

If you configure cron jobs from only 1 user, you won't be able to reproduce the problem.





Expected result:
----------------
Just normal cron output, or nothing. But not error lines.

Actual result:
--------------
If you have logging disabled, your admin mail account will receive mails like this:

"No log handling enabled - turning on stderr logging
Cannot rename /var/net-snmp/snmpapp.conf to /var/net-snmp/snmpapp.1.conf
Cannot unlink /var/net-snmp/snmpapp.conf
"

OR

"
No log handling enabled - turning on stderr logging
read_config_store open failure on /var/net-snmp/snmpapp.conf
read_config_store open failure on /var/net-snmp/snmpapp.conf
read_config_store open failure on /var/net-snmp/snmpapp.conf
"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-01-29 07:50 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Feb 22 22:01:25 2020 UTC