php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40192 isset return true and not false
Submitted: 2007-01-22 09:22 UTC Modified: 2007-01-22 09:31 UTC
From: gordon dot franke at skytecag dot com Assigned:
Status: Not a bug Package: Filter related
PHP Version: 5.2.0 OS: windows and linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: gordon dot franke at skytecag dot com
New email:
PHP Version: OS:

 

 [2007-01-22 09:22 UTC] gordon dot franke at skytecag dot com
Description:
------------
the isset function return true and not false

Reproduce code:
---------------
$var = 'fwefewfwe';
var_dump(isset($var['error']));

Expected result:
----------------
false

Actual result:
--------------
true

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-01-22 09:31 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Sep 30 22:05:55 2022 UTC