php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40170 Warning: ftp_put(): php_connect_nonb() failed: No route to host (65)
Submitted: 2007-01-19 15:50 UTC Modified: 2007-01-19 15:56 UTC
From: eddie at eschnell dot com Assigned:
Status: Not a bug Package: FTP related
PHP Version: 4.4.4 OS: FreeBSD 4.11-STABLE
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: eddie at eschnell dot com
New email:
PHP Version: OS:

 

 [2007-01-19 15:50 UTC] eddie at eschnell dot com
Description:
------------
Warning: ftp_put(): php_connect_nonb() failed: No route to host (65)

I get this error with the reproduce code. it also says Warning: ftp_put(): Type set to I.

It is not uploading the file correctly.

i have php 4.4.1 on iPowerWeb's server, so no upgrade is possible.

Thanks in Advance

Reproduce code:
---------------
$conn_id = ftp_connect("ftpServer");
$login_result = ftp_login($conn_id, "userName", "passWord");
ftp_pasv($conn_id, true);
if ((!$conn_id) || (!$login_result)) {
       echo "FTP connection has failed!";
       echo "Attempted to connect to stp server for user username";
       exit;
   } else {
       echo "Connected to ftp server, for user user";
   }
$upload = ftp_put($conn_id, "bgd.txt", "bgdlocal.txt", FTP_BINARY);
if (!$upload) {
       echo "FTP upload has failed!";
   } else {
       echo "Uploaded $source_file to $ftp_server as $destination_file";
   }
// close the FTP stream
ftp_close($conn_id); 

Expected result:
----------------
Uploaded $source_file to $ftp_server as $destination_file

Actual result:
--------------
Warning: ftp_put(): php_connect_nonb() failed: No route to host (65) in /home/beachgla/public_html/catalog/update/index.php on line 475

Warning: ftp_put(): Type set to I. in /home/beachgla/public_html/catalog/update/index.php on line 475

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-01-19 15:56 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Jul 04 03:03:50 2022 UTC