php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #40077 Make lint check multiple files
Submitted: 2007-01-09 15:48 UTC Modified: 2021-07-18 04:22 UTC
Votes:12
Avg. Score:3.8 ± 0.9
Reproduced:7 of 8 (87.5%)
Same Version:3 (42.9%)
Same OS:3 (42.9%)
From: david at acz dot org Assigned: cmb (profile)
Status: No Feedback Package: *General Issues
PHP Version: 5.2.0 OS: Any
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: david at acz dot org
New email:
PHP Version: OS:

 

 [2007-01-09 15:48 UTC] david at acz dot org
Description:
------------
It would be nice if lint mode checked multiple files:

php -l foo.php bar.php
No syntax errors detected in foo.php
No syntax errors detected in bar.php

If not possible, it should give a warning when multiple files are specified.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-07-07 13:03 UTC] cmb@php.net
-Status: Open +Status: Wont fix -Package: Feature/Change Request +Package: *General Issues -Assigned To: +Assigned To: cmb
 [2021-07-07 13:03 UTC] cmb@php.net
This is unlikely to happen, for similar reasons why
php_check_syntax() has been removed not long after it had been
introduced (see bug #27406).
 [2021-07-07 13:07 UTC] nikic@php.net
I think this could work fine as long as we start a new request for each lint.
 [2021-07-07 13:21 UTC] cmb@php.net
-Status: Wont fix +Status: Feedback
 [2021-07-07 13:21 UTC] cmb@php.net
Ah, right, but are we willing to add complexity for this
perfomance gain?
 [2021-07-18 04:22 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jul 24 11:01:23 2021 UTC