php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40049 Closing an SSL connection results in a Segmentation fault
Submitted: 2007-01-07 16:44 UTC Modified: 2007-01-07 18:03 UTC
From: bugs dot php dot net at daskalou dot com Assigned:
Status: Not a bug Package: cURL related
PHP Version: 5.2.0 OS: CentOS 3.8 (Linux Kernel 2.4.20)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bugs dot php dot net at daskalou dot com
New email:
PHP Version: OS:

 

 [2007-01-07 16:44 UTC] bugs dot php dot net at daskalou dot com
Description:
------------
When using either the curl_close() or fclose() functions on an open HTTPS/SSL connection (open with either the curl functions or fopen() or fsockopen()) using the PHP CLI, I get this:

Segmentation fault (core dumped)

Note that the problem only occurs when using the HTTPS protocol but not with the HTTP protocol.

Others are having this same problem with HTTPS/SSL access but it looks like the PHP developers are saying it's not a bug with PHP but rather with MySQL:

http://bugs.php.net/bug.php?id=39570
http://bugs.php.net/bug.php?id=38393

My current installation details are:

PHP 5.2
MySQL 5.0.27-0
Apache 1.3.37
Hosted on a CentOS 3.8 installation (which includes cPanel)

This bug was not present when I had PHP 4.4.3 and MySQL 5.0.25 installed.

Reproduce code:
---------------
$fp = fopen("https://webmail.optusnet.com.au/", "r");
fclose($fp);
echo "done!";

Expected result:
----------------
It should print out "done!"

Actual result:
--------------
Segmentation fault (cored dumped)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-01-07 18:03 UTC] iliaa@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

The reason is that MySQL and libcurl are linked against 
different SSL libraries.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Sep 21 17:01:27 2019 UTC