php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40027 PHP Java Integration
Submitted: 2007-01-05 07:31 UTC Modified: 2007-01-05 15:16 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: mcharlesrk at yahoo dot com Assigned:
Status: Not a bug Package: Java related
PHP Version: 5.2.0 OS: windows 2000
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: mcharlesrk at yahoo dot com
New email:
PHP Version: OS:

 

 [2007-01-05 07:31 UTC] mcharlesrk at yahoo dot com
Description:
------------
When i add jvm.dll in my php.ini, my sample.php throws 500 internal server error.

I am using php 5.2.0 , pecl 5.2.0 , jdk 1.5.0_04, apache 2.2.3

john@php.net says "The Java extension is not available in PHP 5." 

is it true???

my php.ini 
-----------
extension=php_java.dll
[Java]
java.class.path = "C:\php\ext\php_java.jar; E:\Java\jdk1.5.0_04\jre\lib;E:\Java\jdk1.5.0_04;D:\charles\projects\java"
java.home = "E:\Java\jdk1.5.0_04"
java.library.path="c:\php\ext;E:\Java\jdk1.5.0_04\jre\lib"
java.library=E:\Java\jdk1.5.0_04\jre\bin\server\jvm.dll




Reproduce code:
---------------
sample.php
-----------
<?php
  $system = new Java("java.lang.System");
  print "Java version=".$system->getProperty("java.version")." <br>\n";
  print "Java vendor=".$system->getProperty("java.vendor")." <p>\n\n";
  print "OS=".$system->getProperty("os.name")." ". $system->getProperty("os.version")." on ". $system->getProperty("os.arch")." <br>\n"; $formatter = new Java("java.text.SimpleDateFormat","EEEE, MMMM dd, yyyy 'at' h:mm:ss a zzzz");
  print $formatter->format(new Java("java.util.Date"))."\n";
?>

Expected result:
----------------
javav version = xx
java vendor = xxx
OS = xx


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-01-05 15:16 UTC] iliaa@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Java is not a core PHP extension.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Jan 27 23:03:33 2022 UTC