php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39966 XML/DOM/DBASE issue ?
Submitted: 2006-12-27 20:02 UTC Modified: 2007-01-04 01:00 UTC
From: francois at b-powers dot be Assigned:
Status: No Feedback Package: dBase related
PHP Version: 4.4.4 OS: FC1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: francois at b-powers dot be
New email:
PHP Version: OS:

 

 [2006-12-27 20:02 UTC] francois at b-powers dot be
Description:
------------
This config is working:

'./configure' '--with-apxs=/usr/local/apache/bin/apxs' '--prefix=/usr/local' '--with-xml' '--enable-bcmath' '--enable-calendar' '--enable-ftp' '--with-gd' '--with-jpeg-dir=/usr/local' '--with-png-dir=/usr' '--with-xpm-dir=/usr/X11R6' '--with-mcrypt' '--enable-magic-quotes' '--with-mysqli' '--with-mysql=/usr' '--enable-discard-path' '--with-pear' '--enable-sockets' '--enable-track-vars' '--with-ttf' '--with-freetype-dir=/usr' '--enable-gd-native-ttf' '--with-zlib' '--enable-dbase' '--with-curl' 

This config as well:

'./configure' '--with-apxs=/usr/local/apache/bin/apxs' '--prefix=/usr/local'
'--with-xml' '--enable-bcmath' '--enable-calendar' '--with-curl' '--with-dom'
'--with-dom-xslt' '--with-dom-exslt' '--enable-ftp' '--with-gd'
'--with-jpeg-dir=/usr/local' '--with-png-dir=/usr' '--with-xpm-dir=/usr/X11R6'
'--with-mcrypt' '--enable-magic-quotes' '--with-mysqli' '--with-mysql=/usr'
'--enable-discard-path' '--with-pear' '--enable-xslt' '--with-xslt-sablot'
'--enable-sockets' '--enable-track-vars' '--with-ttf'
'--with-freetype-dir=/usr' '--enable-gd-native-ttf' '--with-xmlrpc'
'--with-zlib'

but if i add enable dbase to the second one, Apache keeps failing.

Thanks,
Francois

Reproduce code:
---------------
'./configure' '--with-apxs=/usr/local/apache/bin/apxs' '--prefix=/usr/local'
'--with-xml' '--enable-bcmath' '--enable-calendar' '--with-curl' '--with-dom'
'--with-dom-xslt' '--with-dom-exslt' '--enable-ftp' '--with-gd'
'--with-jpeg-dir=/usr/local' '--with-png-dir=/usr' '--with-xpm-dir=/usr/X11R6'
'--with-mcrypt' '--enable-magic-quotes' '--with-mysqli' '--with-mysql=/usr'
'--enable-discard-path' '--with-pear' '--enable-xslt' '--with-xslt-sablot'
'--enable-sockets' '--enable-track-vars' '--with-ttf'
'--with-freetype-dir=/usr' '--enable-gd-native-ttf' '--with-xmlrpc'
'--with-zlib' '--enable-dbase'

Expected result:
----------------
Apache working

Actual result:
--------------
Apache Failing

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-12-27 20:08 UTC] tony2001@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.



 [2006-12-27 20:23 UTC] francois at b-powers dot be
I read the link provided, what else info do you need ?  

Can someone confirm that XML/DOM/DBASE is compiling fine with Apache 1.3.37 ?

Thanks,
Francois
 [2006-12-27 20:30 UTC] tony2001@php.net
What is the meaning of "Apache Failing" ?
 [2006-12-27 20:57 UTC] francois at b-powers dot be
It doesn't start.  Please contact your sysadmin.  No error found in the logs.

Just this when doing a "top":

With one httpd process running in loop:

2305 root      25   0 13924 8976 1864 R 98.5%  0.4   1:16.67 httpd

Only one process httpd is present and is taking all server ressources, 98.5% and no webpage can be seen.

Thanks,
Francois
 [2006-12-27 21:07 UTC] tony2001@php.net
>It doesn't start. Please contact your sysadmin.
If it doesn't start, then where did you see the "Please contact your sysadmin" message?
How do you start it? Why do you think it's PHP problem? Does it start without PHP? Does it start with PHP built using minimal configuration? What do you get if you start it manually with `httpd -X` ?
 [2006-12-27 21:14 UTC] francois at b-powers dot be
I'm on a Cpanel server, i saw that message there when restarting.

When restarting it manually in ssh: service httpd restart, i got, httpd restarted, so it's like running.  But no pages can be seen online.

I think it's PHP related as it's not Cpanel and that compiling php is working fine except when i add --enable-dbase after my xml, dom, config.

What other info do you need ?

Thanks.
 [2006-12-27 21:27 UTC] tony2001@php.net
Please figure out what is the minimal PHP configuration which causes problems.
 [2007-01-04 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jan 27 02:01:24 2020 UTC