php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39932 Compilation silently fails to produce CGI executable
Submitted: 2006-12-22 15:27 UTC Modified: 2006-12-27 19:15 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: memotype at gmail dot com Assigned:
Status: Not a bug Package: *Compile Issues
PHP Version: 5.2.0 OS: AIX 5.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: memotype at gmail dot com
New email:
PHP Version: OS:

 

 [2006-12-22 15:27 UTC] memotype at gmail dot com
Description:
------------
Compiling with the --enable-cgi (which should be default anyways, right?) does not produce a cgi executable in sapi/cgi. --enable-cli also does not produce any executable in sapi/cli. I am running on AIX 5.2 with GCC version 2.9

/opt # uname -a
AIX dorap1 2 5 002103CB4C00

/opt # gcc -v
Reading specs from /bin/../lib/gcc-lib/powerpc-ibm-aix5.1.0.0/2.9-aix51-020209/specs
gcc version 2.9-aix51-020209

I have tried this with the latest snapshot, but it does not work either (in fact the latest snapshot doesn't work as an apache module either, but that's another issue...)

Reproduce code:
---------------
~/aix-web/php-5.2.0 $ cat compile.php5
./configure --with-gcc --prefix=/usr/local/php5 \
  --with-apxs2=/usr/local/apache2/bin/apxs \
  --enable-fastcgi \
  --with-config-file-path=/usr/local/apache2/conf \
  --with-gd --with-zlib-dir=/opt/freeware/lib \
  --enable-shared --enable-static --enable-cgi \
  --with-png --with-zlib --with-xml

I've tried various other similar configure lines...

Expected result:
----------------
I expected to find a file named "php" marked as executable in the sapi/cgi subdirectory. This all works fine in Linux, I get executables, etc, but not here in AIX.

Actual result:
--------------
No executable.

I can provide a full log of the compilation process on request.

Thanks a bunch! :)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-12-22 15:34 UTC] memotype at gmail dot com
ohh yeah, incase it isn't clear, the compile succeeds without errors. the apache module is built and everything, it simply doesn't produce the executables. Very odd.
 [2006-12-22 15:37 UTC] tony2001@php.net
"--enable-shared --enable-static" can be safely removed.
Please try to update GCC and check if it works with some modern version.
 [2006-12-22 16:49 UTC] memotype at gmail dot com
I have installed GCC version 4.1.1 from here: http://aixpdslib.seas.ucla.edu/packages/gcc.html and binutils version 2.17 from here: http://aixpdslib.seas.ucla.edu/packages/binutils.html ... these are the latest binaries I can find available for AIX version 5.2. This does not seem to fix the problem: the build operates identically as before.
 [2006-12-22 17:02 UTC] tony2001@php.net
Cannot reproduce on AIX 5.1 with gcc 3.4.5 and native ld. What kind of linker do you use?
 [2006-12-22 18:06 UTC] memotype at gmail dot com
I was linking with the GNU linker from GNU binutils version 2.17, but I have just tried with the native linker with no change in outcome.
 [2006-12-22 18:58 UTC] tony2001@php.net
Please put your Makefile somewhere and post the URL here.
I'd also appreciate if you tell me what versions of the buildtools you use.
 [2006-12-22 19:18 UTC] memotype at gmail dot com
I have pasted my makefile here:
http://pastebin.com/843321

As for build tools, I'm assuming you mean what version of make? I'm using the native AIX make program. I can't seem to get GNU make to run, says it's missing libintl.so.3 which I can't find anywhere...
 [2006-12-22 19:32 UTC] tony2001@php.net
Ahha.. that might be the reason. libintl.so is a part of GNU gettext package (http://aixpdslib.seas.ucla.edu/packages/gettext.html), please install it and use GNU make.
 [2006-12-27 18:06 UTC] memotype at gmail dot com
I hope everyone enjoyed the holiday break. :)

Anyways, I got GNU Make 3.81 working. This time the compilation process created an executable in the sapi/cli directory, but not in the sapi/cgi one. However, the cli one seems to work how the cgi one should...

thanks :)
 [2006-12-27 18:17 UTC] tony2001@php.net
>This time the compilation process created an executable in 
>the sapi/cli directory, but not in the sapi/cgi one. 

Since you're using --with-apxs2, you should get CLI and Apache module, but not CGI.

>However, the cli one seems to work how the cgi one should...

What do you mean by this?
 [2006-12-27 19:05 UTC] memotype at gmail dot com
Never mind, I guess I misunderstood how the CLI engine was supposed to work. Looks like this bug turned out to be merely due to a misconfigured system. Thanks.
 [2006-12-27 19:15 UTC] tony2001@php.net
No problem.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Feb 19 17:01:32 2020 UTC