php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39895 flex version is not properly detected (mostly harmless)
Submitted: 2006-12-20 09:31 UTC Modified: 2006-12-20 09:56 UTC
From: gabriel at oxeva dot fr Assigned:
Status: Not a bug Package: Compile Warning
PHP Version: 5.2.0 OS: Linux 2.6
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: gabriel at oxeva dot fr
New email:
PHP Version: OS:

 

 [2006-12-20 09:31 UTC] gabriel at oxeva dot fr
Description:
------------
the configure script does not detect properly the 2-digit flex versions :
checking for flex version... invalid
configure: WARNING: flex versions supported for regeneration of the Zend/PHP parsers: 2.5.4  (found: 2.5.33).

This bug will be harmless for most users, but it is still a wrong warning ;)

Reproduce code:
---------------
launch configure script with flex >= 2.5.10


Expected result:
----------------
flex >= 2.5.10 detected as newer than 2.5.4 required

Actual result:
--------------
configure: WARNING: flex versions supported for regeneration of the Zend/PHP parsers: 2.5.4  (found: 2.5.33).


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-12-20 09:56 UTC] derick@php.net
This is not a bug, we don't support newer versions than 2.5.4 (because they broke backwards compatibility).
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Nov 29 08:01:23 2020 UTC