php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39877 Unable to load dynamic library
Submitted: 2006-12-18 21:26 UTC Modified: 2006-12-19 10:06 UTC
From: rob4you at vodafone dot it Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 5.2.0 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: rob4you at vodafone dot it
New email:
PHP Version: OS:

 

 [2006-12-18 21:26 UTC] rob4you at vodafone dot it
Description:
------------
PHP 5.2.0 installed as Apache module (apache version 2.2.3) on Windows XP.
I've also tried with PHP 5.2.1RC2-dev, PHP 5.1.2. 
I've used also Apache 2.0.x as webserver.

The php.ini is correctly configured with the wanted extensions (extension=php_name.dll) and the right extensions_dir.
The Apache server is correctly configured with the PHPIniDir and LoadModule directive.

The problem is the following:
when the server starts, SOME extensions are not loaded, and the following warning is produced (as an example):

PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\\Programs\\PHP\\ext\\php_curl.dll' - Impossible to locate specified module.\r\n in Unknown on line 0

The extension is instead correctly placed in the right directory.

It's quite strange that some extensions are loaded, some other are not loaded, but they are all in the SAME directory! 

ps: i've not used environment variable because in the manual it says it not necessary when using php as apache module. 
If I set instead the environment variable Path C:\Programs\PHP it works.

However the behaviour for the problem previously exposed is unexpected: some extensions are correctly loaded, others no.




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-12-18 21:58 UTC] rob4you at vodafone dot it
After try & errors i've observed that I need to copy some dll in the C:\Windows\system32.

But the problem still persists with just three library:

php_pdf.dll
php_pop3.dll
php_smtp.dll

How can I make them working?
 [2006-12-18 22:12 UTC] rob4you at vodafone dot it
Sorry, the last three libraries were not in the extension directory.
So the problem is resolved.

So the way to make working extensions which require other .dll is to copy the last in the c:\windows\system32 (or setting up an environment variable)?
This solutions however is not so good when having multiple PHP version installed on different webserver on the same machine.
 [2006-12-19 00:45 UTC] edink@php.net
This is not a bug in php. Your php folder (C:\Programs\PHP) needs to be included in PATH. After modifying path you need to restart your machine for the changes to take effect for all services.
 [2006-12-19 10:06 UTC] rob4you at vodafone dot it
ok, that's not a bug. 
But this means that two installations of php cannot exist on the same machine, because one between the two will cause many problems.
This is not specified on the manual.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Feb 28 13:01:27 2024 UTC