php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39829 php was not using the php_mysqli.dll
Submitted: 2006-12-14 08:09 UTC Modified: 2006-12-14 08:18 UTC
From: crunchpack at gmail dot com Assigned:
Status: Not a bug Package: MySQLi related
PHP Version: 5.2.0 OS: windows xp sp2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: crunchpack at gmail dot com
New email:
PHP Version: OS:

 

 [2006-12-14 08:09 UTC] crunchpack at gmail dot com
Description:
------------
the php_mysqli.dll is not being located.

Things done:

I uncommented the extension=php_mysql.dll, extension=php_mysqli.dll(actually added it to the php.ini file).
Placed the libmysqli.dll,libmysql.dll,php_mysqli.dll in the windows/system32/ directory.



Reproduce code:
---------------
<?
//error is in the next line
$mysqli = new mysqli('localhost','root','iiitb');
$mysqli->select_db('demo');

$result = $mysqli->query("SELECT * FROM members");

while($row = $result->fetch_assoc()) {
print $row['firstName'] . ' ' . $row['lastName'] . '<br/>';
}



?>

Expected result:
----------------
display the values in the table 'members'.

Actual result:
--------------
class mysqli.dll is not found in c:\webs\test\mysqltest.php on line 3.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-12-14 08:18 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Aug 11 05:05:45 2022 UTC