php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #39818 "any English textual datetime description" is ambigious
Submitted: 2006-12-13 15:19 UTC Modified: 2007-08-17 11:22 UTC
From: ian at ithomas dot name Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS: All
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ian at ithomas dot name
New email:
PHP Version: OS:

 

 [2006-12-13 15:19 UTC] ian at ithomas dot name
Description:
------------
The one line summary of strtotime is "Parse about any English textual datetime description into a Unix timestamp".

This should be clarified to "Parse about any US English textual datetime description into a Unix timestamp" (addition of US).


If you're American and reading this, please don't think it is not important just because it works fine for you. Imagine if it worked the other way round, and strtotime('2/4/2006') output 2nd April, and your IDE was telling you that this function parsed English dates (meaning dates used in England)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-08-17 11:22 UTC] vrana@php.net
Summary is simplified, function description is correct.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jul 11 22:01:24 2020 UTC