php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39781 Can't Install/Server Gives Error
Submitted: 2006-12-08 22:22 UTC Modified: 2008-08-22 17:37 UTC
From: ggxtreme at gmail dot com Assigned: jmertic (profile)
Status: Closed Package: Windows Installer
PHP Version: 5.2.0 OS: Windows XP Professional Edition
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ggxtreme at gmail dot com
New email:
PHP Version: OS:

 

 [2006-12-08 22:22 UTC] ggxtreme at gmail dot com
Description:
------------
I am trying to setup PHP 5.2.0 for an Abyss server that will host an RSS feed.  When I run the Windows msi installer for 5.2.0, I choose "Other CGI server".  But when it gets close to the end and says "Error trying access the local web service: GetObject Failed. You will need to manually configure IIS via the management console.", then it says "There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.".  I do not plan on using IIS at all.  I am trying to stream music to my PSP, following the guide step-by-step from PSP 411 <http://www.psp411.com/show/guide/44/0/Streaming_Music_From_Your_PC_To_Your_PSP.html>.

Reproduce code:
---------------
This is the RSS php script: <http://www.dclxvi.nl/psp_rss/oldversion.asp>

Expected result:
----------------
Some sort of RSS feed directory page (or anything besides 13 errors).

Actual result:
--------------
I tried ignoring the errors, but when I tried to access the Abyss server, it tried to load the index.php file with php 5.2.0 and I got several error messages:

-"This application has failed to start because php_mbstring.dll was not found. Re-installing the application may fix this problem." (Waiting 20 seconds produces an "Error 500" page.)
-Same error, but with 'isqlt09a.dll'
-Same error, but with 'OCI.dll' (3 times)
-Same error, but with 'aspell-15.dll'
-Same error, but with 'libcs.dll'
-Same error, but with 'DB2CLI.dll'
-Same error, but with 'CORE_RL_magick_.dll'
-Same error, but with 'iilibapi.dll'
-Same error, but with 'lcrzo.dll'
-Same error, but with 'OCIW32.dll'
-Same error, but with 'intl3_svn.dll'
-"The procedure entry point _ZOOM_scanset_display_term@16 could not be located in the dynamic link library yaz.dll." (Waiting 20 seconds produces an "Error 504" page.)
-"CGI / FastCGI has encountered a problem and needs to close.  We are sorry for the inconvenience." (Waiting 20 seconds produces an "Error 500" page.)

I have tried reinstalling and picking 'Do not set up webserver', but the same thing happens. I have followed the guide exactly, unless the whole thing is wrong. It has worked for other people I know.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-12-12 16:38 UTC] jmertic@php.net
I cannot reproduce this with the installer. I would try fully uninstalling PHP and trying to reinstall again.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Nov 28 04:03:17 2021 UTC