php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39753 ftp_connect() fail
Submitted: 2006-12-06 14:22 UTC Modified: 2006-12-06 14:49 UTC
From: alek dot silverstone at gmail dot com Assigned:
Status: Not a bug Package: FTP related
PHP Version: 5.2.0 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: alek dot silverstone at gmail dot com
New email:
PHP Version: OS:

 

 [2006-12-06 14:22 UTC] alek dot silverstone at gmail dot com
Description:
------------
This script failed after 1000-2000 loops.

Reproduce code:
---------------
<?php
  set_time_limit(0);
  $i=1;

  while (TRUE)
  {
    $date=date('H:i:s');
    $ftp=ftp_connect('127.0.0.1',21,10);
    if ($ftp) $login=ftp_login($ftp,'anonymous',$i);
    if ($ftp && $login)
    {
      if (($i % 100) === 0) echo "[$date] $i - online.\n";
    } else {
      echo "[$date] $i - offline.\n";
      break;
    }
    @ftp_close($ftp); $i++;
  }
?>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-12-06 14:49 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon May 23 18:05:46 2022 UTC