php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39735 crash
Submitted: 2006-12-04 20:54 UTC Modified: 2006-12-04 22:13 UTC
From: roberto at spadim dot com dot br Assigned:
Status: Closed Package: SQLite related
PHP Version: 5.2.0 OS: linux 2.6.10
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: roberto at spadim dot com dot br
New email:
PHP Version: OS:

 

 [2006-12-04 20:54 UTC] roberto at spadim dot com dot br
Description:
------------
PHP 5.1.6

php: ./src/pager.c:1237: syncJournal: Assertion `pPg->needSync==0' failed.

this message never appeared before

after an error on my test php i get 1082M of memory use
i killed php process, swapoff and swapon
after this php any file got this message, i will reboot system to get new messages

Reproduce code:
---------------
any code 
<?php
$a=10;
?>

i think that's an problem with memory allocation

Expected result:
----------------
continue script run

Actual result:
--------------
php: ./src/pager.c:1237: syncJournal: Assertion `pPg->needSync==0' failed.
Aborted

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-12-04 21:02 UTC] tony2001@php.net
The error comes from SQLite, which means it didn't like the fact that you killed the process, when it was syncing the data on the disk.
Not PHP problem.
 [2006-12-04 21:09 UTC] roberto at spadim dot com dot br
this occur after sqlite_query("COMMIT TRANSACTION",$LINK);

i didn't killed the process, neither kernel

COMMIT TRANSACTION
php: ./src/pager.c:1237: syncJournal: Assertion `pPg->needSync==0' failed.
Aborted
 [2006-12-04 21:11 UTC] iliaa@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

You need to report this bug to sqlite devs, PHP uses stock 
sqlite library so any assertion failures would imply bugs in 
the lib itself.
 [2006-12-04 21:13 UTC] roberto at spadim dot com dot br
i got the error:
see sqlite_query():

COMMIT TRANSACTION;
begin transaction;
PRAGMA default_synchronous=NORMAL;
PRAGMA auto_vacuum=1;
PRAGMA synchronous=NORMAL;
PRAGMA default_temp_store=MEMORY;
PRAGMA temp_store=MEMORY;
PRAGMA case_sensitive_like=0;
PRAGMA encoding=\"UTF-8\";
COMMIT TRANSACTION; <-- here php(sqlite) crash

could we send this bug to sqlite team?
 [2006-12-04 21:24 UTC] iliaa@php.net
Please do, they have a bug tracker at http://www.sqlite.org/
 [2006-12-04 22:13 UTC] roberto at spadim dot com dot br
ok done
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Jan 18 17:01:24 2021 UTC