php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #39694 transformToDoc() vs. transformToDocument()
Submitted: 2006-11-30 15:47 UTC Modified: 2013-05-16 09:49 UTC
From: lbzwischenbrugger at fh-stpoelten dot ac dot at Assigned:
Status: Not a bug Package: XSLT related
PHP Version: 5CVS-2006-11-30 (CVS) OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: lbzwischenbrugger at fh-stpoelten dot ac dot at
New email:
PHP Version: OS:

 

 [2006-11-30 15:47 UTC] lbzwischenbrugger at fh-stpoelten dot ac dot at
Description:
------------
The method transformToDoc() should be called transformToDocument().



Reproduce code:
---------------
PHP Syntax:
-----------
http://at.php.net/xsl-xsltprocessor-transform-to-doc
$processor=new XSLTProcessor();
$processor->importStyleSheet($xsldomObject);
$result=$processor->transformToDoc($domObject);


Javascript Syntax:
------------------
http://developer.mozilla.org/en/docs/The_XSLT/JavaScript_Interface_in_Gecko:Interface_List
processor=new XSLTProcessor();
processor.importStyleSheet(xsldomObject);
result=processor.transformToDocument(domObject);



Patches

transformToDoc_to_transformToDocument (last revision 2013-05-16 10:25 UTC by craigtaub at hotmail dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-02-21 21:17 UTC] jani@php.net
-Package: Feature/Change Request +Package: XSLT related -Operating System: all +Operating System: *
 [2013-05-16 09:49 UTC] stas@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

This is released API, so changing it would be a BC issue.
 [2013-05-16 09:49 UTC] stas@php.net
-Status: Open +Status: Not a bug
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Dec 11 16:01:26 2019 UTC