php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39666 "Message-ID" from gmail mails not appearing.
Submitted: 2006-11-28 20:49 UTC Modified: 2006-11-28 21:11 UTC
From: sgattas at fibertel dot com dot ar Assigned:
Status: Not a bug Package: Mail related
PHP Version: 5.2.0 OS: Linux (64 bits)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sgattas at fibertel dot com dot ar
New email:
PHP Version: OS:

 

 [2006-11-28 20:49 UTC] sgattas at fibertel dot com dot ar
Description:
------------
Using standard imap functions to grab and store mails, I need to keep track of the Message-ID (and References and In-Reply-To) to build threads. 
I can successfully do it with mails sent from a lot of different accounts to my email test account but every mail sent from a gmail account does not have a Message-ID when I fetched it with a php script.
I checked the same mails from my thunderbird (sent the same mail to another account and downloaded it with TB) and I verified that a Message-ID indeed exists.
It seems "References" exists and lists all "Message-ID" in the thread except the one from gmail. 

I suspect it's due to the extension (in characters) of gmail Message-ID (it always seems larger than the other ones)




Reproduce code:
---------------
$mbox = imap_open("{imap.domain:143/imap}INBOX",$user,$pass);
 if($mbox)
 {  
     $nmsg=imap_num_msg($mbox);
  for ($i=1; $i<=$nmsg; $i++) {
   $header = imap_header($mbox, $i); 
   print_r($header); echo '<br><br>';
  }
 }
 else
 {
     echo 'Connection failed<br>';
 }
imap_close($mbox);
}

Expected result:
----------------
In mails sent from a gmail account I expect to get a Message-ID in the header as defined in RFC822.


Actual result:
--------------
In mails sent from gmail I get a null value in Message-ID although I know that a Message-ID exists.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-11-28 21:05 UTC] tony2001@php.net
Try to update c-client library (which is actually used by ext/imap) to the latest available version (the package is usually called imap-lib-200x or imap-200x) and rebuild PHP using the new library.
If that doesn't help, please report this problem to c-client developers.
Thank you.
 [2006-11-28 21:11 UTC] sgattas at fibertel dot com dot ar
I'm using imap-2006d.DEV.SNAP-0611201609. It's as new as it gets.
If you say I should try over there, I will.
Any news regarding php I will bring them back.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jan 26 14:03:33 2022 UTC