php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39630 Commands out of sync, php-latest don't resolve problem
Submitted: 2006-11-25 20:37 UTC Modified: 2006-11-27 15:42 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: wijet at o2 dot pl Assigned:
Status: Not a bug Package: MySQLi related
PHP Version: 5.2.0 OS: Linux x86
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
23 + 4 = ?
Subscribe to this entry?

 
 [2006-11-25 20:37 UTC] wijet at o2 dot pl
Description:
------------
I have problem when I run query after this procedule call
mysqli_query('CALL my_procedure('.$foo.')')
I always get error 
"Commands out of sync; you can't run this command now",on mysql docs I read that I must use mysqli_free_result but this do nothing.
I try use php-5.1.6 ,5.2.0 an 5.2 latest cvs but for all version i get this error.


Reproduce code:
---------------
mysqli_query('CALL my_procedure('.$foo.')')

mysqli_query('SELECT * FROM test')

Expected result:
----------------
execute query

Actual result:
--------------
"Commands out of sync; you can't run this command now"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-11-27 10:04 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 [2006-11-27 15:42 UTC] wijet at o2 dot pl
problem resolved when I use this config http://gcov.php.net/viewer.php?version=PHP_5_2&func=system
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 17 17:05:44 2022 UTC