php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39626 php.ini not installed in C:\Windows
Submitted: 2006-11-25 02:27 UTC Modified: 2008-08-22 18:37 UTC
From: michael dot k dot henry at gmail dot com Assigned:
Status: Not a bug Package: Windows Installer
PHP Version: 5.2.0 OS: Windows XP Pro SP2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: michael dot k dot henry at gmail dot com
New email:
PHP Version: OS:

 

 [2006-11-25 02:27 UTC] michael dot k dot henry at gmail dot com
Description:
------------
Hi,

I have just installed PostgreSQL 8.1, Apache 2.2, and PHP 5.2 on my computer. When loading a page that called pg_connect() I got an error that pg_connect() could not be found.

phpinfo() showed that "Configuration File (php.ini) Path" was "C:\WINDOWS".

The PHP installer did not put a php.ini file in C:\WINDOWS. Instead it left php.ini in my installation folder "C:\Program Files\PHP". Copying php.ini to C:\WINDOWS resolved the problem.

Regards,

    Michael




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-11-25 10:06 UTC] nlopess@php.net
this is not a bug. We do not recommend you to put the php.ini file in the windows dir, but left it in the instalation dir.
If the env var PHPRC is set, PHP will be able to pick your php.ini (and I think the instaler does that - but you need to restart the pc).
 [2006-11-25 12:44 UTC] michael dot k dot henry at gmail dot com
You're right - the installer has created the environment variable PHPRC. But it didn't reboot the computer or suggest that I do so. Would it be possible to add that step to the installation?

Regards,

    Michael
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Nov 28 02:03:13 2021 UTC