|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39589 Configure/compilation ignoring --with-pcre-regex=DIR parameter?
Submitted: 2006-11-22 14:51 UTC Modified: 2006-11-30 01:00 UTC
From: jordi at telematictraining dot com Assigned:
Status: No Feedback Package: *Compile Issues
PHP Version: 5.2.0 OS: GNU/Linux Debian stable
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
Solve the problem:
5 + 2 = ?
Subscribe to this entry?

 [2006-11-22 14:51 UTC] jordi at telematictraining dot com
Due to issue 39415 with PCRE 6.7, we tried to compile php 5.2.0 with our own compilation of PCRE 6.6 by giving php's configure the parameter --with-pcre-regex=DIR parameter (in instance, --with-pcre-regex=/usr/local as long as we configured that prefix for PCRE).

The thing is that configure didn't complained, but once php got compiled, phpinfo() showed that the PCRE version compiled is another: the one that's installed on /usr/, that is, the current version available on the Debian stable repositories (4.5-1.2sarge1).

In the config.log the things seem to be ok since it seems to obtain the version that was requested on the configure:


Reproduce code:
See description.

Expected result:
Have the PCRE 6.6 version compiled into php 5.2.0 as we're pointing php's configure the right place to get PCRE 6.6 headers & libs from, instead of configure's actual behaving (taking the other system wide PCRE version, 4.5-1.2sarge1).

Actual result:
PCRE 4.5-1.2sarge1 is the one that gets compiled on php 5.2.0.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2006-11-22 14:58 UTC]
Not reproducible.
 [2006-11-22 15:58 UTC] jordi at telematictraining dot com
Forgot to mention a couple of things.

1) PCRE 6.6 was compiled with the following configure line:

./configure --prefix=/usr/local --disable-cpp --enable-utf8

2) In addition to this, at the moment of executing php's 5.2.0 configure with --with-pcre-regex=/usr/local/lib, the configure complained because it did not find pcre.h, which is normal taking in consideration that that is placed on /usr/local/include by PCRE 6.6 make install once executed. We copied the requested header file (pcre.h) to /usr/local/lib just to get things compiled, but the described issue also appeared.

We did --with-pcre-regex=/usr/local/lib instead of --with-pcre-regex=/usr/local because the result of that last option gave same result: the PCRE compiled was 4.5-1.2sarge1 instead of 6.6 one.
 [2006-11-22 21:37 UTC]
I'm still unable to reproduce this.
Please fix the headers mess in your system and try to rebuild it again.
 [2006-11-30 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Jan 21 05:03:33 2022 UTC