php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39580 Incorrect Error in Configure PDO
Submitted: 2006-11-22 08:15 UTC Modified: 2007-09-06 11:12 UTC
From: drh1 at cec dot wustl dot edu Assigned: wez (profile)
Status: No Feedback Package: Compile Failure
PHP Version: 5.2CVS-2006-11-22 OS: Mac OS 10.4.8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: drh1 at cec dot wustl dot edu
New email:
PHP Version: OS:

 

 [2006-11-22 08:15 UTC] drh1 at cec dot wustl dot edu
Description:
------------
When running configure with PHP 5.2.0 on Mac OS X, the 
following error is returned:

Base configure command:
'./configure' '--enable-pdo=shared'    

Error
Due to the way that loadable modules work on OSX/Darwin, you 
need to
compile the PDO package statically into the PHP core.

Please follow the instructions at: http://netevil.org/
node.php?nid=202
for more detail on this issue.

This error is inaccurate.  This problem was solved for 5.1.x 
and should still be solved for 5.2.0

Reproduce code:
---------------
'./configure' '--enable-pdo=shared'

Expected result:
----------------
proper configuration success

Actual result:
--------------
error:
Due to the way that loadable modules work on OSX/Darwin, you 
need to
compile the PDO package statically into the PHP core.

Please follow the instructions at: http://netevil.org/
node.php?nid=202
for more detail on this issue.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-11-22 10:22 UTC] johannes@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.2-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.2-win32-latest.zip
 [2006-11-22 13:40 UTC] drh1 at cec dot wustl dot edu
This error still occurs in php5.2-200611221130 .
 [2006-11-22 13:48 UTC] drh1 at cec dot wustl dot edu
Since I apparently tested 1 minute before CVS updated, 
php5.2-200611221330 doesn't work either .
 [2007-09-05 13:58 UTC] jani@php.net
Fix version field. Does this problem exist with PHP 5.2.4?
Note: This report was lost due to invalid version number. First char in the version field is supposed to be the major version number!!
 [2007-09-05 14:22 UTC] drh1 at cec dot wustl dot edu
I no longer have a mac, so I cannot provide feedback.
 [2007-09-06 11:12 UTC] jani@php.net
So we let this rot.
 [2007-10-30 21:47 UTC] jesse at mcmds dot com
Yes, the problem still occurs in 5.2.4.


checking whether to enable PDO support... yes, shared
configure: error: 
Due to the way that loadable modules work on OSX/Darwin, you need to
compile the PDO package statically into the PHP core.

Please follow the instructions at: http://netevil.org/node.php?nid=202
for more detail on this issue.
          
x1:/vol/build/php-5.2.4 root#
 [2007-10-30 22:01 UTC] jesse at mcmds dot com
Might also be helpful to note that I did not have any difficulty compiling 5.1.4 with shared PDO on this same machine. Unfortunately we are running into an unrelated bug on our dev server that was fixed in 5.2.0, so I needed to upgrade.
 [2009-05-22 08:40 UTC] norm at cackhanded dot net
This still occurs because the code has yet to be removed from configure. 
Lines 37-50 from ext/pdo/config.m4 need to be deleted. Without that 
code, PHP with PDO compiles fine on my Leopard box.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Feb 29 02:01:28 2024 UTC