php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39427 cancel_upload parameter get wrong value when using multi field upload form
Submitted: 2006-11-08 09:01 UTC Modified: 2006-11-08 19:14 UTC
From: krudtaa at yahoo dot com Assigned:
Status: Not a bug Package: HTTP related
PHP Version: 5.2.0 OS: Windows XP Pro
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: krudtaa at yahoo dot com
New email:
PHP Version: OS:

 

 [2006-11-08 09:01 UTC] krudtaa at yahoo dot com
Description:
------------
When using the new APC_UPLOAD_PROGRESS feature and
if you make a multi file upload_form and do not fill out all of the file fields then the
cancel_upload parameter get a value of 4 and the the whole upload is reported as:

Cancelled after 109300234 bytes

even if the upload actually was a success.



Reproduce code:
---------------
Download this source:
http://progphp.com/progress.phps

which I found at:
http://talks.php.net/show/torkey06/24

then change the upload_form so it have more than one upload
field.

I entered three fields like this:

<input type="file" name="test_file[]"/><br/>
<input type="file" name="test_file[]"/><br/>
<input type="file" name="test_file[]"/><br/>

Expected result:
----------------
I would like to see PHP, or the APC extension (do not know which one causes the error) not raise any errors when some of the file fields are not filled out.

Actual result:
--------------
cancel_upload parameter should get value of 0 and not 4.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-11-08 19:14 UTC] tony2001@php.net
Duplicate of http://pecl.php.net/bugs/bug.php?id=9263, Gopal said he'll take care of it.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Oct 01 17:03:45 2022 UTC