php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39385 International friendly mktime alternative
Submitted: 2006-11-04 21:00 UTC Modified: 2006-11-07 14:38 UTC
From: thehub at lofty dot net dot au Assigned:
Status: Closed Package: *Languages/Translation
PHP Version: 4.4.4 OS: any
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: thehub at lofty dot net dot au
New email:
PHP Version: OS:

 

 [2006-11-04 21:00 UTC] thehub at lofty dot net dot au
Description:
------------
I've had to make my own mkdate function to call mktime and rearrange the params because mktime uses the usa-only format that doesn't make mathematical sense. Please add these functions to the standard php date/time functions.

Reproduce code:
---------------
mkdate($day[, $month[, $year]])

mkitime($second[, $minute[, $hour[, $day[, $month[, $year[, $is_dst]]]]]]))

mkidate($year[, $month[, $day[, $hour[, $minute[, $second[, $is_dst]]]]]])

Expected result:
----------------
Give the writer of the original mktime function a good whack upside the head for me, for thinking that repeating a mistake enough times will make it right.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-11-07 14:38 UTC] bjori@php.net
Thank you for your bug report. This issue has already been fixed
in the latest released version of PHP, which you can download at 
http://www.php.net/downloads.php

Have a look at the DateTime object in 5.2.0
(will not be fixed in PHP4).
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jan 20 07:01:23 2020 UTC