php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #393 linking problem
Submitted: 1998-05-21 13:36 UTC Modified: 1998-05-21 20:47 UTC
From: otto dot frost at mal dot frontec dot se Assigned:
Status: Closed Package: Sybase (dblib) related
PHP Version: 3.0 Release Candidate 4 OS: redhat linux 5.0 and 4.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: otto dot frost at mal dot frontec dot se
New email:
PHP Version: OS:

 

 [1998-05-21 13:36 UTC] otto dot frost at mal dot frontec dot se
./configure --with-sybase-ct=/home/otfr/sybase --with-config-file-path=/home/otfr/php3/lib





at end of make:

gcc -O2   -I. -I.        -I/home/otfr/sybase/include       -g -Wall   -c functions/velocis.c -o functions/velocis.o
gcc -O2   -I. -I.        -I/home/otfr/sybase/include       -g -Wall   -o php   language-parser.tab.o language-scanner.o main.o hash.o operators.o variables.o token_cache.o stack.o internal_functions.o snprintf.o php3_sprintf.o alloc.o list.o highlight.o debugger.o configuration-parser.tab.o configuration-scanner.o request_info.o safe_mode.o fopen-wrappers.o  functions/adabasd.o functions/apache.o functions/fhttpd.o functions/basic_functions.o functions/crypt.o functions/datetime.o functions/db.o functions/dbase.o functions/dir.o functions/dl.o functions/dns.o functions/exec.o functions/file.o functions/filepro.o functions/filestat.o functions/formatted_print.o functions/fsock.o functions/gd.o functions/head.o functions/html.o functions/image.o functions/link.o functions/mail.o functions/math.o functions/md5.o functions/microtime.o functions/mime.o functions/msql.o functions/mysql.o functions/oracle.o functions/pack.o functions/pageinfo.o functions/pgsql.o functions/post.o functions/rand.o functions/reg.o functions/solid.o functions/soundex.o functions/string.o functions/syslog.o functions/type.o functions/uniqid.o functions/sybsql.o functions/sybase.o functions/sybase-ct.o functions/url.o functions/base64.o functions/info.o functions/number.o functions/bcmath.o functions/unified_odbc.o functions/ldap.o functions/browscap.o functions/velocis.o    regex/libregex.a -lgd -lm -ldl -lcrypt  -lgdbm -L/home/otfr/sybase/lib -lcs -lct -lcomn -lintl -lsybtcl -linsck 
gcc: Internal compiler error: program ld got fatal signal 11
make: *** [php] Error 1
[otfr@sydux01 php-3.0RC4]$ 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-05-21 20:47 UTC] zeev
Obviously, this isn't PHP's fault.  The problem is that
the Sybase CT library was converted from a.out format,
and doesn't seem to like many versions of GNU binutils.
Try upgrading to the latest binutils, if it doesnt work
try compiling binutils yourself (the latest version
available as an RPM from redhat may not be the latest
version).
Note:
1.  This will NOT work under RH 5.0 - the Sybase CT
library doesn't work with glibc2.
2.  Upgrading binutils can be hazardous.  Don't do it
unless you know what you're doing.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jan 26 15:01:25 2020 UTC