php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39288 Upload failed with file name like {1E0557DF-2797-4E31-9908-81722ABCED19}0.jpg
Submitted: 2006-10-28 06:15 UTC Modified: 2006-10-28 09:33 UTC
From: chenlailin at gmail dot com Assigned:
Status: Not a bug Package: HTTP related
PHP Version: 5.1.6 OS: WindowXP SP2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: chenlailin at gmail dot com
New email:
PHP Version: OS:

 

 [2006-10-28 06:15 UTC] chenlailin at gmail dot com
Description:
------------
upload photo with the name {1E0557DF-2797-4E31-9908-81722ABCED19}0.jpg
It won't work, rename it to 
xxxxx.jpg,
It works.

Here is the code I used:

$uploadFileWithoutPath = "photos".basename($_FILES['PhotoUpload']['name']);

$uploadFileWithoutPath = urlencode($uploadFileWithoutPath);

$uploaddir = $PhotoDir;
$uploadfile = $uploaddir . $uploadFileWithoutPath;
$uploadfile = sprintf($uploadfile,time());

$requestValid = true;
$fileSize = $_FILES['PhotoUpload']['size'];

if($fileSize > 1000000)
{
   $requestValid = false;
}

if (move_uploaded_file($_FILES['PhotoUpload']['tmp_name'], $uploadfile)) {

  //do my stuff here.......

Reproduce code:
---------------
http://lab.mytalentexchange.com/ 

Click a location, and click "add marker" link, try to upload a photo with the name {1E0557DF-2797-4E31-9908-81722ABCED19}0.jpg

It won't upload the photo, now rename it to 
xxxxx.jpg,
It works.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-10-28 09:33 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Oct 24 04:03:35 2021 UTC