php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39274 php.ini not being read
Submitted: 2006-10-27 06:39 UTC Modified: 2006-10-27 09:04 UTC
From: campbell at neotext dot ca Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.4.4 OS: Fedora Core 6
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: campbell at neotext dot ca
New email:
PHP Version: OS:

 

 [2006-10-27 06:39 UTC] campbell at neotext dot ca
Description:
------------
PHP 4.4.4 built on Core  6 with 
./configure  --with-apxs2=/usr/local/apache/bin/apxs --with-mysql=/usr/local/mysql --with-openssl=/usr --with-zlib-dir=/usr/local/src/mysql-4.1.21/zlib --with-gd --with-imap=/usr/local/src/imap-2006c --with-imap-ssl=/usr  --with-config-file-path=/etc/php.ini

Loading this build lib to Apache2.059 on Fedora Core 6
fails to load(find?) the php.ini file anywhere I put it.

Not sure if it's me or a bug yet...

Dhu

Reproduce code:
---------------
change safe_mode=Off to safe_mode=On in php.ini
save, restart apache, run php_info() in a test.php.

Expected result:
----------------
I expect to see safe_mode set to "on"

Actual result:
--------------
I observe safe_mode still set to "off"

Similarly with other parameter defs.

Dhu

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-10-27 06:48 UTC] rasmus@php.net
phpinfo() or php -i would tell you where it is looking.

You want --with-config-file-path=/etc
not --with-config-file-path=/etc/php.ini


 [2006-10-27 07:10 UTC] campbell at neotext dot ca
Hi.  I did it everywhichway.   

Yes. Running phpinfo tells me where it is reading,
which is where I expect, but the parms in the ini
file are not being read.  

I'm going to run the same build/install on clean core4 now
and see what happens...

Dhu
 [2006-10-27 07:11 UTC] campbell at neotext dot ca
Hi.  I did it everywhichway.   

Yes. Running phpinfo tells me where it is reading,
which is where I expect, but the parms in the ini
file are not being read.  

I'm going to run the same build/install on clean core4 now
and see what happens...

Dhu
 [2006-10-27 07:23 UTC] campbell at neotext dot ca
Same revs of apache, mysql and php, build similar build, 
on FreeBSD 6.1-RELEASE behaves correctly.  

D~
 [2006-10-27 07:45 UTC] tony2001@php.net
--with-config-file-path=/etc/php.ini - this configure option accepts DIRECTORY as its value.

 [2006-10-27 07:50 UTC] campbell at neotext dot ca
yes.  the config-file-path parm takes either or... I tried
that early on. I'm building a clean Core4 to try this on
and will let you know what happens.  I'm thinking this 
is a Fedora bug, but it his here.
 [2006-10-27 07:59 UTC] tony2001@php.net
Show us your phpinfo().
 [2006-10-27 08:08 UTC] campbell at neotext dot ca
This is a can, as I'm using that machine 
to build the Core4 on now:
http://neotext.ca/tmp/phpinfo.sneet.html

This is a working FBSD 6.1
http://atlas.indx.ca/tmp/test.php
and a working FBSD 6.2 PRERELEASE
 [2006-10-27 08:10 UTC] campbell at neotext dot ca
This is a can, as I'm using that machine 
to build the Core4 on now:
http://neotext.ca/tmp/phpinfo.sneet.html

This is a working FBSD 6.1
http://atlas.indx.ca/tmp/test.php
and a working FBSD 6.2 PRERELEASE
.. sorry (cutoff)..
http://neotext.ca/test.php
 [2006-10-27 08:33 UTC] campbell at neotext dot ca
This is a can, as I'm using that machine 
to build the Core4 on now:
 which doesn't werk the same ... needs a static build..
boggle..
 [2006-10-27 08:41 UTC] tony2001@php.net
I repeat, --with-config-file-path takes DIRECTORY.
Please rebuild it using --with-config-file-path=/etc instead.

 [2006-10-27 08:57 UTC] campbell at neotext dot ca
so, I stick the C6 drive back and rebuild. and yess.  it
works now ... so this still bugs me, because my original
config line had no reference to --with-config-file-path
and the thing did not want to be found in /usr/local/lib
or /etc ...

Thanks all.
 [2006-10-27 09:04 UTC] campbell at neotext dot ca
closed
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Aug 11 00:05:46 2022 UTC