php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39233 Windows MSI installer cannot configure Apache 2.2
Submitted: 2006-10-23 09:49 UTC Modified: 2008-08-22 17:36 UTC
From: matt at genesi-usa dot com Assigned: jmertic (profile)
Status: Closed Package: Windows Installer
PHP Version: 5.2.0RC5 OS: Windows XP Home SP2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: matt at genesi-usa dot com
New email:
PHP Version: OS:

 

 [2006-10-23 09:49 UTC] matt at genesi-usa dot com
Description:
------------
The apacheconfig.php script bundled with the new MSI installer breaks; when selecting a directory from the installer, a semicolon is appended to the path. When it is passed to the script, the script builds configuration filenames as:

C:\Program Files\Apache Software Foundation\Apache2.2\conf\;httpd.conf

Fixing that error, it fails to backup the httpd.conf and mime.types files before editing.

Reproduce code:
---------------
Select Apache 2.2 module from the list, pick a directory.

I fixed it by changing:

$foldername = str_replace(array('"', ';\\'), array('','\\'), $argv[2]);

Also even though I run as Administrator for the purposes of installing, the two backup checks fail for some reason. I didn't look into this so I just commented that entire elseif statement out for both files (I don't need a backup it was a fresh Apache 2.2 install with the default configuration file)




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-10-24 12:10 UTC] jmertic@php.net
Added removal of ';' in $foldername, and tweaked check for file ( using is_file() instead of file() ) now in CVS.
 [2006-10-25 17:51 UTC] matt at genesi-usa dot com
the (!copy(httpd.conf, httpd.conf.bak)) check still fails here for some reason (permission denied?)
 [2006-10-30 12:51 UTC] jmertic@php.net
I cannot reproduce this at all. If it's a permissions issue then I would double check that the current user has full access to that file and folder.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 01 16:03:34 2021 UTC