|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #39163 Invalid API call from php5isapi.dll causing IIS7 Application Pool failure.
Submitted: 2006-10-16 02:45 UTC Modified: 2007-08-25 01:00 UTC
Avg. Score:4.6 ± 0.8
Reproduced:40 of 43 (93.0%)
Same Version:24 (60.0%)
Same OS:25 (62.5%)
From: tony dot stone at gmail dot com Assigned:
Status: No Feedback Package: Documentation problem
PHP Version: 5.2.3 OS: Windows Vista RC 1 Build 5600
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Bug Type:
From: tony dot stone at gmail dot com
New email:
PHP Version: OS:


 [2006-10-16 02:45 UTC] tony dot stone at gmail dot com
I've seen a few other people post concerning random crashes, but my issue can be reproduced every time I try to access any web page on my server since configuring it to use php5isapi.dll

I am running Vista RC1 build 5600 with IIS 7 installed.  php5isapi.dll appears to be making an API call not recognized by the OS.  Ever since I installed PHP my DefaultAppPool stops when I access any web page on my server and it creates an error (Event ID 2295; Data 7F000000) in the Application Log.

Details from App Log:
- System 

  - Provider 

   [ Name]  Microsoft-Windows-IIS-W3SVC-WP 
   [ Guid]  {670080D9-742A-4187-8D16-41143D1290BD} 
   [ EventSourceName]  W3SVC-WP 
  - EventID 2295 

   [ Qualifiers]  49152 
   Version 0 
   Level 2 
   Task 0 
   Opcode 0 
   Keywords 0x80000000000000 
  - TimeCreated 

   [ SystemTime]  2006-10-16T02:05:59.000Z 
   EventRecordID 1205 
  - Execution 

   [ ProcessID]  0 
   [ ThreadID]  0 
   Channel Application 
   Computer epsilon 
- EventData 

  ModuleDll C:\Inetpub\PHP\php5isapi.dll 


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2006-10-17 00:43 UTC] tony dot stone at gmail dot com
PHP isn't crashing so there's no way to get a backtrace (that I know of).  I did download the debug files and install them, but there's no popup or window of any sort that would allow me to click Cancel or enter a debug view.  PHP isn't technically crashing.  php5isapi.dll
is making an API call to the OS via the DefaultAppPool in IIS7 and the DefaultAppPool is shutting down and generating an event log error, which reads, "Failed to find the RegisterModule entrypoint in the module DLL C:\Inetpub\PHP\php5isapi.dll.  The data is the error."

Maybe I'm just not getting it, but I don't see any way to get the backtrace info per the directions ( based on this behavior.
 [2006-10-17 07:42 UTC]
Does it work with 5.2.0 snapshots from ?

 [2006-10-17 11:03 UTC] tony dot stone at gmail dot com
No it doesn't.  I installed the following version:

16 Oct 2006 12:40:40 +0200
Version: 5.2.0RC6-dev
 [2006-11-18 05:56 UTC] jussi dot palo at gmail dot com
Having the same issue on 5.2.0 on Vista RTM. Have tried with php5isapi.dll as well as php-cgi.exe, both give me the same error as described in the bug report. This error occurs every time I try to access .php pages.
 [2007-01-15 12:21 UTC] miha_avzlahar at t-2 dot net
I guess I have same problem with php5isapi.dll. Or am I? 
I am running Windows Vista Ultimate. Trying to set up MySQL 5.0.27 and PHP 5.2.0, but I always get this bull... in browser :
Server Error in Application "Default Web Site"
HTTP Error 500.0 - Internal Server Error

Description: Calling LoadLibraryEx on ISAPI filter "C:\php\php5isapi.dll" failed

Error Code: 0x800700c1

Notification: Unknown

Module: IIS Web Core

Requested URL: http://localhost:80/wp-admin/install.php

Physical Path: E:\FTProot\www\mihavista\wp-admin\install.php

Logon User: Not yet determined

Logon Method: Not yet determined

Handler: StaticFile

And this in event viewer :

ISAPI Filter 'C:\php\php5isapi.dll' could not be loaded due to a configuration problem. The current configuration only supports loading images built for a AMD64 processor architecture. The data field contains the error number. To learn more about this issue, including how to troubleshooting this kind of processor architecture mismatch error, see

WTF ??? Any suggestions ?
 [2007-02-06 14:01 UTC] andreasblixt at msn dot com
This issue is also occurring for me on an AMD64 computer with IIS 7 running on Windows Vista x64 RTM using php-5.2.0-Win32.

From what I can gather, the issue seems to be related to the fact that I'm running a 64-bit version of Windows Vista/IIS 7.
 [2007-02-09 13:02 UTC] Dirk at KISSsoft dot nl
It's a IIS 7/PHP bug.

When i enable support for 32-bit (on AMD-64) in the default application pool it happens.
 [2007-03-05 09:49 UTC] ruSS at GEobYTeS dot com
I am runnning Vista Buisness (Build 6000) on an Intel (Core 2 Duo) 6400 - same issue as first post.

- System 

  - Provider 

   [ Name]  Microsoft-Windows-IIS-W3SVC-WP 
   [ Guid]  {670080D9-742A-4187-8D16-41143D1290BD} 
   [ EventSourceName]  W3SVC-WP 
  - EventID 2295 

   [ Qualifiers]  49152 
   Version 0 
   Level 2 
   Task 0 
   Opcode 0 
   Keywords 0x80000000000000 
  - TimeCreated 

   [ SystemTime]  2007-03-05T09:34:05.000Z 
   EventRecordID 562 
  - Execution 

   [ ProcessID]  0 
   [ ThreadID]  0 
   Channel Application 

- EventData 

  ModuleDll C:\inetpub\PHP\php-5.2.1-Win32\php5isapi.dll 
 [2007-03-19 22:21 UTC] dontmsgme at gmail dot com
I am also having this issue.  I have tried BillS' installation method as well as FastCGI with no luck.  I am thinking it might be related to the 64bit OS.  I see that someone else tried 32 bit application compatibility with no luck.

Is anyone having this problem NOT on a 64bit OS?
 [2007-03-27 15:00 UTC] loz_hurst at hotail dot com
I am having this issue on 32-bit vista on a 32bit processor, so it may not be a 64bit issue.
 [2007-04-13 23:14 UTC] sneakers05 at optusnet dot com dot au
I had similar probs running php4isapi.dll with IIS7 on Vista x64 Ultimate. Moving to php5 isn't an option for me because I'm developing for a particular machine running php4. 

I can't get the isapi version of php running, but after a bit (lot!) of messing around have got the php.exe version working sweet. :)

Here's what I did:
1. Remove all ISAPI filters for PHP.
2. Ensure you have a handler mapping for PHP as follows:
c:\php\php.exe (or whatever path you are using)
3. Under Application Pools in IIS Manager, right clicked DefaultAppPool and went to Advanced Settings. Ensure "Enable 32-bit applications" is set to True. I also set Process Orphaning:Enabled to True, even though I have *no* idea what it is for!
4. Ensured php.ini was in my c:\windows folder and the cgi.force_redirect is set to 0 and uncommented.

I also did the following which may or may not be required:
1. Right clicked the PHP folder and selected Properties, Security.
2. Clicked on Advanced, Edit, Add.. and for the object name to select, entered: IUSR.
3. Clicked OK and gave IUSR full control to the folder.
4. Repeated steps 2 and 3 but for IIS_IUSRS.
5. Applied the changes and clicked on OK to exit the PHP folder properties window.

I also did the following which probably isn't needed:
1. Copied php4ts.dll into my c:\windows\system32 folder
2. Stood on one foot while chanting to the rain gods and focussing my mental energy on my "power animal" - the llama. :)

Hope this helps others, even if it doesn't resolve the isapi side of things!

 [2007-05-04 10:02 UTC] gruddzr at yahoo dot com
i also have the same problem, using vista premium here
 [2007-05-09 15:05 UTC] FreakTrap at gmail dot com
sneakers05's modification of the Application Pool's 32-bit setting also corrected the problem I was having with the php5isapi.dll.

For those of us getting the 'Calling LoadLibraryEx on ISAPI filter "C:\PHP\php5isapi.dll" failed' error after an attempted manual install:

1) *Start with a fresh IIS installation with both ISAPI filters and extensions enabled.
2) Under the main settings [at the very top of your IIS Manager's hierarchy view, above Application Pools], add the following in this order:
2.1) an ISAPI Filter for php5isapi.dll
2.2) a ISAPI and CGI Restriction entry for php5isapi.dll
2.3) a Handler Mapping for php5isapi.dll
3) Go to the application Pools section.
4) Right-click on Default Application Pool and select Advanced Settings.
5) Set the second option [Enable 32-Bit...] to True.

Now everything should work...

* Also, it is important that your 'Default Website' not have any unique settings from the top-level configurations.  This was causing my ISS to exhibit some pretty strange behavior, which is why I recommend that you first delete your default website and create a new one.
 [2007-07-22 23:19 UTC]
See above comments how to fix it.
 [2007-07-22 23:20 UTC]
On second thought, this needs better documenting. Reclassified as such.
 [2007-08-17 12:40 UTC]
What exactly and where should be documented?
 [2007-08-25 01:00 UTC] phpdoc at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2008-10-15 19:08 UTC] comspex at ict dot ne dot jp
The following is the function in question -- RegisterModule.

IIS7 seems requiring it.

The same error also occurs to php5.dll and php5ts.dll for cgi version.

New version of NetBeans is planning to enable PHP development.  IIS7 users cannot use it until this problem fixed...

Waiting for a good news...
 [2009-03-13 13:29 UTC] sl4y3r1995 at ymail dot com
I've a same problem, exactly, about this dll file bug. But the version of PHP and IIS that I use is different. I'm using Windows Vista RTM build 6000 Ultimate Edition, PHP version 5.2.9 with IIS 7 Server installed as HTTP server.

ErrorType : AppCrash
FaultModule : php5isapi.dll
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Jun 25 08:01:23 2021 UTC