php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39155 linking issues with make install
Submitted: 2006-10-14 00:14 UTC Modified: 2006-10-22 01:00 UTC
Votes:3
Avg. Score:3.7 ± 0.9
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: ruiner at netslacking dot net Assigned:
Status: No Feedback Package: *Compile Issues
PHP Version: 5.1.6 OS: Solaris 9
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ruiner at netslacking dot net
New email:
PHP Version: OS:

 

 [2006-10-14 00:14 UTC] ruiner at netslacking dot net
Description:
------------
Similar issues to http://bugs.php.net/36901

Linking fails upon make install:

Installing PEAR environment:      /usr/local/lib/php/
ld.so.1: php: fatal: relocation error: file /usr/share/src/php-5.1.6/sapi/cli/php: symbol: referenced symbol not found

The same symbol reference error comes up when I try to run apachectl start (or restart).

My config line:

./configure --with-apxs2=/www/usr/apache/bin/apxs --with-mysql=/usr/local/mysql --with-mysqli --with-gettext --with-openssl --with-libxml-dir=/usr/local/lib --enable-soap --with-xmlrpc --enable-xslt --enable-libgcc --enable-static

I tried making a static build to circumvent linking issues, but it still is trying to make it shared/dynamic.

I downloaded, built and installed GNU binutils (including GNU ld) but still have problems (and yes, I made distclean before ./configure'ing again).  Could this be a problem with ld.so itself?  That file was not updated upon installation of new ld, so I'm guessing it's the default Solaris one.  How/where do I get a different one?

I have also tried to get a precompiled version, but it still has issues finding xmlTextReaderGetAttribute.  I have built a new version of libxml2 also, to no avail.  Any help would be greatly appreciated.  FYI, I'm building PHP so I can run MediaWiki.  Could I perhaps build without XML/PEAR support?

Thanks


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-10-14 00:21 UTC] ruiner at netslacking dot net
make install error should read:

Installing PEAR environment:      /usr/local/lib/php/
ld.so.1: php: fatal: relocation error: file
/usr/share/src/php-5.1.6/sapi/cli/php: symbol: xmlTextReaderGetAttribute referenced symbol not
found
 [2006-10-14 10:50 UTC] tony2001@php.net
What version of libxml2 do you use?
Why do you think GNU ld is used?
 [2006-10-14 17:29 UTC] ruiner at netslacking dot net
libxml2 2.6.18

checking for ld used by /usr/local/bin/gcc... /usr/local/bin/ld
checking if the linker (/usr/local/bin/ld) is GNU ld... yes
 [2006-10-14 17:57 UTC] tony2001@php.net
What if you try to build a newer libxml2?
 [2006-10-22 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2007-08-26 02:34 UTC] ab5602 at wayne dot edu
This is an issue with your LD_LIBRARY_PATH.  Your installation is finding an old library for libxml2.  Adding your current xml libs to the beginning of your library path before executing fixed it for me.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 01 01:03:34 2021 UTC