php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39106 date("w") incompatible with date("W")
Submitted: 2006-10-10 10:42 UTC Modified: 2006-10-10 10:53 UTC
From: felixmallek at gmx dot de Assigned:
Status: Not a bug Package: Calendar related
PHP Version: 5.1.6 OS: n/a
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: felixmallek at gmx dot de
New email:
PHP Version: OS:

 

 [2006-10-10 10:42 UTC] felixmallek at gmx dot de
Description:
------------
Hi,
I'm creating a calendar using the date() function.
I want to show in this calendar the Week-number, but there are two different standarts: 
1) date("w") has Sunday as the first day of the week
2) date("W") has Monday as the first day of the week

I think it's rubbish because the different standarts makes a calendar awkward.

I think it would be not bad to edit one of standarts in the next Version of PHP or in one of the following updates.

Thanks
Felix



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-10-10 10:53 UTC] tony2001@php.net
Expected and well documented behaviour, no bug here.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Mar 30 23:01:24 2020 UTC