php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39096 OCI8 fails to load fully
Submitted: 2006-10-09 15:05 UTC Modified: 2006-10-10 11:30 UTC
From: peter dot wilton-jones at eads dot com Assigned:
Status: Not a bug Package: OCI8 related
PHP Version: 5.1.6 OS: Windows 2003 Server
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: peter dot wilton-jones at eads dot com
New email:
PHP Version: OS:

 

 [2006-10-09 15:05 UTC] peter dot wilton-jones at eads dot com
Description:
------------
When upgrading from 5.0.5 to 5.1.6 I am unable to get php_oci8.dll to load correctly.

I am using all of the same parameters that I used in 5.0.5 and have even tried the same php,ini file but it fails to load.

I do NOT get an error saying that php_oci8.dll cannot be found and it is definately UN-commented in php.ini.

When I then attempt an oci_connect or oci_pconnect, I get an error saying 
"Fatal error: Call to undefined function oci_connect() in ........"

Examining phpinfo, no entry for oci8 exists however the location of php.ini is correct.

Both 5.0.5 and 5.1.6 are set up in the same way and oci.dll is in the same location therefore is cannot be Oracle Library errors.

I have tried both the php_oci8.dll that came with the distribution and from http://pecl4win.php.net/ext.php/php_oci8.dll (5.1.2) but both produced the same error.

Reproduce code:
---------------
$ora_handler = oci_connect ("myusername", "mypassword", "mydatabase");

Actual result:
--------------
No output was given apart from error "Fatal error: Call to undefined function oci_connect() in ........"


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-10-09 16:39 UTC] tony2001@php.net
You must install Oracle Instant Client in order to use newer versions of OCI8 on Windows.
 [2006-10-10 08:53 UTC] peter dot wilton-jones at eads dot com
Attempted that and now it had loaded the libraries into PHPINFO but produces another error ORA-12705. This instantly points at the environment but this does not appear to be the reason.

I have removed all references to ORACLE and then placed the following Enviromnents
PATH=c:\ociClient;c:\php;.....
LD_LIBRARY_PATH=c:\ociClient
TNS_ADMIN=c:\ociClient

All files from the Client Libraries are in c:\ociClient

I have attempted to use the onld TNSNAMES.ora file as previously working but this failed and I have also attempted to write the SID manually but all fail.

This now appears to be another problm from the origional but still does not appear to work fully.
 [2006-10-10 11:30 UTC] peter dot wilton-jones at eads dot com
Problem Resolved.

This was not a PHP issue, sorry for raising the bug report for a non bug. Please close this case.

For your information. The resolution was to edit the registry HKLM/Software/Oracle by renaming NLS_LANG to xLNS_LANG.
This is not an issue if you have never installed the Full Oracle Client.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Jul 21 02:01:29 2024 UTC