php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #390 Wrong MySQL-dir crashes PHP
Submitted: 1998-05-20 14:20 UTC Modified: 1998-05-23 07:06 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: tobias at dnet dot it Assigned:
Status: Closed Package: Installation problem
PHP Version: 3.0 Release Candidate 4 OS: FreeBSD 2.2.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tobias at dnet dot it
New email:
PHP Version: OS:

 

 [1998-05-20 14:20 UTC] tobias at dnet dot it
Having a binary of MySQL 3.21 installed in /usr/local/mysql, I specified this directory in the PHP setup script. PHP compiled fine as a Apache-1.3b6-module but failed to start up with a segfault (dumped core). When I specified /usr/local/ as the MySQL-directory, PHP worked fine. More missing error-checking than a bug, I guess, but it took me some hours to get rid of it.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-05-23 07:06 UTC] zeev
There aren't any details in this report to go on...
My guess is that you have some sort of a messup between
several MySQL installations, with header
files from one release and incompatible libraries from
another release (I say that because it happened once to me).

If MySQL was properly installed in just one place, PHP
would have not compiled with both --with-mysql=/usr/local/mysql
and --with-mysql==/usr/local, but just with one of the
two.

If you compile PHP with include files from one release,
and link it with incompatible libraries from another release,
it'll crash.  We can't detect it in any way during
compiletime...
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Dec 05 21:03:39 2021 UTC