php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38988 Chaning mssql.datetimeconvert has no effect
Submitted: 2006-09-29 06:47 UTC Modified: 2006-10-01 22:24 UTC
From: wiggum24 at gmail dot com Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: 5.1.6 OS: Redhat Enterprise Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
37 + 35 = ?
Subscribe to this entry?

 
 [2006-09-29 06:47 UTC] wiggum24 at gmail dot com
Description:
------------
Trying to set mssql.datetimeconvert to Off in php.ini doesn't work. phpinfo() reports it as On, and the behaviour of the recordset reflects the same.

I've confirmed php is picking up the correct php.ini, and my php.ini contains no errors.

Calling ini_set("mssql.datetimeconvert","Off"); before I do the query will set the value and the queries will return correctly.

Reproduce code:
---------------
No errors, the setting just doesn't apply.

Expected result:
----------------
datetimes should appear as:
2006-07-20 16:32:00

Actual result:
--------------
datetimes appear as:
Jul 20 2006 04:32PM

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-09-29 09:09 UTC] tony2001@php.net
>Trying to set mssql.datetimeconvert to Off in php.ini >doesn't work.
>phpinfo() reports it as On, and the behaviour of the >recordset reflects the same.
Which php.ini is used by PHP according to phpinfo()? Which php.ini did you change? Did you restart the web-server?

 [2006-09-29 15:03 UTC] fmk@php.net
Works fine here.

Did you remove ; in front of the line?
 [2006-10-01 22:24 UTC] wiggum24 at gmail dot com
correct php.ini, the ; character was removed. Nothing that silly :)

Found it, I had a php extension that wasn't working properly. No settings were applying after the line that enabled it in php.ini, but php was still working fine and not throwing errors.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed May 25 07:05:45 2022 UTC