php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38981 Adding FTP URL's in the get_headers() function, causes PHP to crash.
Submitted: 2006-09-28 12:40 UTC Modified: 2006-10-04 16:13 UTC
From: trustpunk at gmail dot com Assigned:
Status: Closed Package: Reproducible crash
PHP Version: 5.2.0RC4 OS: Windows XP
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: trustpunk at gmail dot com
New email:
PHP Version: OS:

 

 [2006-09-28 12:40 UTC] trustpunk at gmail dot com
Description:
------------
When you add a simple FTP connection to the get_headers()
function, PHP will crash.

Reproduce code:
---------------
<pre>
<?php
$ftp_server = "ftp://user:pass@host/path/to/file.zip";

//  Let's echo the "header" from the file
print_r(get_headers($ftp_server));
?>
</pre>

Expected result:
----------------
I want the headers from my FTP server request.

Actual result:
--------------
Windows tells me that "PHP" has crashed. Also, I'm testing
this on PHP5.2.0RC5.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-09-28 12:55 UTC] tony2001@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 [2006-10-04 16:09 UTC] trustpunk at gmail dot com
Sorry, but I tried the new and newer CVS Snapshots and it still does not fix the problem. I'm trying to pull the content headers from an FTP server, and all this snapshot does is return false to any FTP URL I give it.

I didn't want to Open this back up but I had to.
 [2006-10-04 16:13 UTC] tony2001@php.net
>I'm trying to pull the content headers from an FTP
>server, and all this snapshot does is return false to any >FTP URL I give it.
That's expected, since there are no headers in FTP.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Sep 18 18:03:39 2021 UTC