php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38879 I've got an error saying: "DB Error: extension not found"
Submitted: 2006-09-19 12:42 UTC Modified: 2006-09-19 12:47 UTC
From: jsbangasan at yahoo dot com Assigned:
Status: Not a bug Package: *Database Functions
PHP Version: 4.4.4 OS: Windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jsbangasan at yahoo dot com
New email:
PHP Version: OS:

 

 [2006-09-19 12:42 UTC] jsbangasan at yahoo dot com
Description:
------------
require_once "DB.php";
$host = 'mysql.positive-internet.com';
$host = 'testhost.com';
$user = 'user1';
$pass ='mjasds';
$db_name ='dbtest';

$dsn = "mysql://$user:$pass@$host/$db_name";
$conn = &DB::connect($dsn);

if (DB::isError($conn)) 
{    
    echo 'Standard Message: ' . $conn->getMessage() . "\n";
    echo 'Standard Code: ' . $conn->getCode() . "\n";
    echo 'DBMS/User Message: ' . $conn->getUserInfo() . "\n";
    echo 'DBMS/Debug Message: ' . $conn->getDebugInfo() . "\n";
}

Reproduce code:
---------------
require_once "DB.php";
$host = 'mysql.positive-internet.com';
$host = 'testhost.com';
$user = 'user1';
$pass ='mjasds';
$db_name ='dbtest';

$dsn = "mysql://$user:$pass@$host/$db_name";
$conn = &DB::connect($dsn);

if (DB::isError($conn)) 
{    
    echo 'Standard Message: ' . $conn->getMessage() . "\n";
    echo 'Standard Code: ' . $conn->getCode() . "\n";
    echo 'DBMS/User Message: ' . $conn->getUserInfo() . "\n";
    echo 'DBMS/Debug Message: ' . $conn->getDebugInfo() . "\n";
}

Expected result:
----------------
would set a $conn as a usable connection object for mysql database

Actual result:
--------------
Standard Message: DB Error: extension not found Standard Code: -25 DBMS/User Message: [DB Error: extension not found] ** mysqli://user1:mjasds@testhost.com/dbtest DBMS/Debug Message: [DB Error: extension not found] ** mysqli://user1:mjasds@testhost.com/dbtest

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-09-19 12:47 UTC] johannes@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

And please change your database password or tell your provider to change it!
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Jul 08 01:01:25 2020 UTC