php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38717 BCC header isn't stripped out
Submitted: 2006-09-05 01:38 UTC Modified: 2006-09-11 22:02 UTC
From: adrianob at gmail dot com Assigned:
Status: Not a bug Package: Mail related
PHP Version: 4.4.4 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: adrianob at gmail dot com
New email:
PHP Version: OS:

 

 [2006-09-05 01:38 UTC] adrianob at gmail dot com
Description:
------------
I'm trying to send an email with Bcc recipients, they get a copy, but the Bcc header isn't stripped out.

I already tested using different character cases, like Bcc, BCC, bcc. And already tested using \n and \r\n as headers glue.

Reproduce code:
---------------
<?php

  mail('from@goobar.com', 'subject', 'message', 'Bcc: email@foobar.com');

?>

Expected result:
----------------
from@goobar.com and email@foobar.com receive the same message, but without one know the other.

Actual result:
--------------
from@goobar.com is receiving the following message:

Subject: subject
Bcc: email@foobar.com

message

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-09-05 08:05 UTC] tony2001@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.



 [2006-09-05 15:57 UTC] adrianob at gmail dot com
Which kind of information do you need? Just ask me.
 [2006-09-08 09:28 UTC] tony2001@php.net
Cannot reproduce with Postfix and PHP4/PHP5.
We need to know at least which mail server you are using.
 [2006-09-11 21:18 UTC] adrianob at gmail dot com
I was checking which MTA is being used, and I guess that is "sSMTP sendmail emulation". Searching more, it seems that the Bcc stripping isn't implemented by it...
Thanks.
 [2006-09-11 22:02 UTC] johannes@php.net
Nothing PHP can change -> bogus
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun May 22 19:03:48 2022 UTC