php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38588 Default value of extension_dir in php.ini is wrong
Submitted: 2006-08-25 08:17 UTC Modified: 2006-08-25 08:21 UTC
From: gmtfn at yahoo dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.1.5 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: gmtfn at yahoo dot com
New email:
PHP Version: OS:

 

 [2006-08-25 08:17 UTC] gmtfn at yahoo dot com
Description:
------------
extension_dir in php.ini is set to "./", by default. Since extension DLLs are located in ext directory in the distributed package, this value should be "./ext/" to reduce installation time.

And pretty much the same request was filed for version 4.3.4 (http://bugs.php.net/bug.php?id=26581&edit=2). I hope the resolution will be different this time. You're supplying a default value anyway, so why not make it so that the distributed package works out of the box?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-08-25 08:21 UTC] tony2001@php.net
Bug #26581 contains a nice explanation of why this was not changed.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Oct 07 12:03:43 2022 UTC