php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38545 sapi/cli/php: symbol xmlTextReaderGetAttribute: referenced symbol not found
Submitted: 2006-08-22 13:35 UTC Modified: 2006-08-22 14:55 UTC
From: wzaccone at telcordia dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.1.5 OS: Solaris 9
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: wzaccone at telcordia dot com
New email:
PHP Version: OS:

 

 [2006-08-22 13:35 UTC] wzaccone at telcordia dot com
Description:
------------
Installing PHP 5.1.5 on Solaris 9 using apache 2.0.55.  Php plugin for apache works, but the make install gave this error at the end.  I researched and saw a previous bug marked bogus indicated to use gnu version of ld.  I tried that and it still got the same error. see below. using the gnu version of ld gets same error on php 5.1.5.



Actual result:
--------------
Installing man pages:             /usr/local/apache/lib/man/man1/
  page: phpize.1
  page: php-config.1
Installing PEAR environment:      /usr/local/apache/lib/php/
ld.so.1: php: fatal: relocation error: file /php-5.1.5/sapi/cli/php: symbol xmlTextReaderGetAttribute: referenced symbol not found
Killed
make[1]: *** [install-pear-installer] Error 137
make: *** [install-pear] Error 2
# which ld
/usr/local/bin/ld


# ld --version
GNU ld version 2.14 20030612
Copyright 2002 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public License.  This program has absolutely no warranty.
#


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-08-22 13:39 UTC] tony2001@php.net
Make sure libxml2 is up to date and compiled using GNU builds tools.
 [2006-08-22 14:48 UTC] wzaccone at telcordia dot com
yes. that fixed it. thank you.  I had an old version of libxml2 in an earlier directory on the LD_LIBRARY_PATH.  I removed and the make install of php 5.1.5 succeeded.
 [2006-08-22 14:55 UTC] tony2001@php.net
Great. Not PHP problem then.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Oct 02 10:05:51 2022 UTC