php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38530 preg_replace_callback() [function.preg-replace-callback]: Unknown modifier '|'
Submitted: 2006-08-21 04:18 UTC Modified: 2006-08-21 08:42 UTC
From: jmazzi at gmail dot com Assigned:
Status: Not a bug Package: PCRE related
PHP Version: 5.1.5 OS: Centos 3 (linux 2.4)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jmazzi at gmail dot com
New email:
PHP Version: OS:

 

 [2006-08-21 04:18 UTC] jmazzi at gmail dot com
Description:
------------
When I updated from php 4 to php 5, one of my apps is giving this error: Warning: preg_replace_callback() [function.preg-replace-callback]: Unknown modifier '|' 

Reproduce code:
---------------
    $text = preg_replace_callback("{
            (?:\\n\\n|\\A)
            (               # $1 = the code block -- one or more lines, starting with a space/tab
              (?:
                (?:[ ]\{$md_tab_width} | \\t)  # Lines must start with a tab or a tab-width of spaces
                .*\\n+
              )+
            )
            ((?=^[ ]{0,$md_tab_width}\\S)|\\Z)  # Lookahead for non-space at line-start, or end of doc
        }xm",
        '_DoCodeBlocks_callback', $text);




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-08-21 08:42 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon May 23 21:03:42 2022 UTC